summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/panic-impl-transitive
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /src/test/run-make-fulldeps/panic-impl-transitive
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/panic-impl-transitive')
-rw-r--r--src/test/run-make-fulldeps/panic-impl-transitive/Makefile7
-rw-r--r--src/test/run-make-fulldeps/panic-impl-transitive/panic-impl-consumer.rs5
-rw-r--r--src/test/run-make-fulldeps/panic-impl-transitive/panic-impl-provider.rs9
3 files changed, 0 insertions, 21 deletions
diff --git a/src/test/run-make-fulldeps/panic-impl-transitive/Makefile b/src/test/run-make-fulldeps/panic-impl-transitive/Makefile
deleted file mode 100644
index c3192efcb..000000000
--- a/src/test/run-make-fulldeps/panic-impl-transitive/Makefile
+++ /dev/null
@@ -1,7 +0,0 @@
-include ../../run-make-fulldeps/tools.mk
-
-# NOTE we use --emit=llvm-ir to avoid running the linker (linking will fail because there's no main
-# in this crate)
-all:
- $(RUSTC) panic-impl-provider.rs
- $(RUSTC) panic-impl-consumer.rs -C panic=abort --emit=llvm-ir -L $(TMPDIR)
diff --git a/src/test/run-make-fulldeps/panic-impl-transitive/panic-impl-consumer.rs b/src/test/run-make-fulldeps/panic-impl-transitive/panic-impl-consumer.rs
deleted file mode 100644
index 82a98b12d..000000000
--- a/src/test/run-make-fulldeps/panic-impl-transitive/panic-impl-consumer.rs
+++ /dev/null
@@ -1,5 +0,0 @@
-#![no_std]
-#![no_main]
-
-// this crate provides the `panic_impl` lang item so we don't need to define it here
-extern crate panic_impl_provider;
diff --git a/src/test/run-make-fulldeps/panic-impl-transitive/panic-impl-provider.rs b/src/test/run-make-fulldeps/panic-impl-transitive/panic-impl-provider.rs
deleted file mode 100644
index f1b9873c8..000000000
--- a/src/test/run-make-fulldeps/panic-impl-transitive/panic-impl-provider.rs
+++ /dev/null
@@ -1,9 +0,0 @@
-#![crate_type = "rlib"]
-#![no_std]
-
-use core::panic::PanicInfo;
-
-#[panic_handler]
-fn panic(info: &PanicInfo) -> ! {
- loop {}
-}