summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/pass-non-c-like-enum-to-c
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/pass-non-c-like-enum-to-c
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/pass-non-c-like-enum-to-c')
-rw-r--r--src/test/run-make-fulldeps/pass-non-c-like-enum-to-c/Makefile5
-rw-r--r--src/test/run-make-fulldeps/pass-non-c-like-enum-to-c/nonclike.rs21
-rw-r--r--src/test/run-make-fulldeps/pass-non-c-like-enum-to-c/test.c85
3 files changed, 111 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/pass-non-c-like-enum-to-c/Makefile b/src/test/run-make-fulldeps/pass-non-c-like-enum-to-c/Makefile
new file mode 100644
index 000000000..f3d935786
--- /dev/null
+++ b/src/test/run-make-fulldeps/pass-non-c-like-enum-to-c/Makefile
@@ -0,0 +1,5 @@
+-include ../tools.mk
+
+all: $(call NATIVE_STATICLIB,test)
+ $(RUSTC) nonclike.rs -L$(TMPDIR) -ltest
+ $(call RUN,nonclike)
diff --git a/src/test/run-make-fulldeps/pass-non-c-like-enum-to-c/nonclike.rs b/src/test/run-make-fulldeps/pass-non-c-like-enum-to-c/nonclike.rs
new file mode 100644
index 000000000..517286a86
--- /dev/null
+++ b/src/test/run-make-fulldeps/pass-non-c-like-enum-to-c/nonclike.rs
@@ -0,0 +1,21 @@
+#[repr(C, u8)]
+pub enum TT {
+ AA(u64, u64),
+ BB,
+}
+
+#[repr(C,u8)]
+pub enum T {
+ A(u64),
+ B,
+}
+
+extern "C" {
+ pub fn t_add(a: T, b: T) -> u64;
+ pub fn tt_add(a: TT, b: TT) -> u64;
+}
+
+fn main() {
+ assert_eq!(33, unsafe { tt_add(TT::AA(1,2), TT::AA(10,20)) });
+ assert_eq!(11, unsafe { t_add(T::A(1), T::A(10)) });
+}
diff --git a/src/test/run-make-fulldeps/pass-non-c-like-enum-to-c/test.c b/src/test/run-make-fulldeps/pass-non-c-like-enum-to-c/test.c
new file mode 100644
index 000000000..99511b253
--- /dev/null
+++ b/src/test/run-make-fulldeps/pass-non-c-like-enum-to-c/test.c
@@ -0,0 +1,85 @@
+#include <stdint.h>
+
+/* This is the code generated by cbindgen 0.12.1 for the `enum TT`
+ * type in nonclike.rs . */
+enum TT_Tag {
+ AA,
+ BB,
+};
+typedef uint8_t TT_Tag;
+
+typedef struct {
+ uint64_t _0;
+ uint64_t _1;
+} AA_Body;
+
+typedef struct {
+ TT_Tag tag;
+ union {
+ AA_Body aa;
+ };
+} TT;
+
+/* This is the code generated by cbindgen 0.12.1 for the `enum T` type
+ * in nonclike.rs . */
+enum T_Tag {
+ A,
+ B,
+};
+typedef uint8_t T_Tag;
+
+typedef struct {
+ uint64_t _0;
+} A_Body;
+
+typedef struct {
+ T_Tag tag;
+ union {
+ A_Body a;
+ };
+} T;
+
+uint64_t tt_add(TT a, TT b) {
+ if (a.tag == AA && b.tag == AA) {
+ return a.aa._0 + a.aa._1 + b.aa._0 + b.aa._1;
+ } else if (a.tag == AA) {
+ return a.aa._0 + a.aa._1;
+ } else if (b.tag == BB) {
+ return b.aa._0 + b.aa._1;
+ } else {
+ return 0;
+ }
+}
+
+uint64_t t_add(T a, T b) {
+ if (a.tag == A && b.tag == A) {
+ return a.a._0 + b.a._0;
+ } else if (a.tag == AA) {
+ return a.a._0;
+ } else if (b.tag == BB) {
+ return b.a._0;
+ } else {
+ return 0;
+ }
+}
+
+TT tt_new(uint64_t a, uint64_t b) {
+ TT tt = {
+ .tag = AA,
+ .aa = {
+ ._0 = a,
+ ._1 = b,
+ },
+ };
+ return tt;
+}
+
+T t_new(uint64_t a) {
+ T t = {
+ .tag = A,
+ .a = {
+ ._0 = a,
+ },
+ };
+ return t;
+}