summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/pretty-print-to-file
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/pretty-print-to-file
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/pretty-print-to-file')
-rw-r--r--src/test/run-make-fulldeps/pretty-print-to-file/Makefile5
-rw-r--r--src/test/run-make-fulldeps/pretty-print-to-file/input.pp3
-rw-r--r--src/test/run-make-fulldeps/pretty-print-to-file/input.rs5
3 files changed, 13 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/pretty-print-to-file/Makefile b/src/test/run-make-fulldeps/pretty-print-to-file/Makefile
new file mode 100644
index 000000000..b224c52fc
--- /dev/null
+++ b/src/test/run-make-fulldeps/pretty-print-to-file/Makefile
@@ -0,0 +1,5 @@
+-include ../tools.mk
+
+all:
+ $(RUSTC) -o $(TMPDIR)/input.out -Zunpretty=normal input.rs
+ diff -u $(TMPDIR)/input.out input.pp
diff --git a/src/test/run-make-fulldeps/pretty-print-to-file/input.pp b/src/test/run-make-fulldeps/pretty-print-to-file/input.pp
new file mode 100644
index 000000000..e3f03242a
--- /dev/null
+++ b/src/test/run-make-fulldeps/pretty-print-to-file/input.pp
@@ -0,0 +1,3 @@
+
+#[crate_type = "lib"]
+pub fn foo() -> i32 { 45 }
diff --git a/src/test/run-make-fulldeps/pretty-print-to-file/input.rs b/src/test/run-make-fulldeps/pretty-print-to-file/input.rs
new file mode 100644
index 000000000..aa828155b
--- /dev/null
+++ b/src/test/run-make-fulldeps/pretty-print-to-file/input.rs
@@ -0,0 +1,5 @@
+#[crate_type="lib"]
+
+pub fn
+foo() -> i32
+{ 45 }