summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/print-cfg
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/print-cfg
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/print-cfg')
-rw-r--r--src/test/run-make-fulldeps/print-cfg/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/print-cfg/Makefile b/src/test/run-make-fulldeps/print-cfg/Makefile
new file mode 100644
index 000000000..5472baae3
--- /dev/null
+++ b/src/test/run-make-fulldeps/print-cfg/Makefile
@@ -0,0 +1,20 @@
+# needs-llvm-components: x86 arm
+
+-include ../tools.mk
+
+all: default
+ $(RUSTC) --target x86_64-pc-windows-gnu --print cfg | $(CGREP) windows
+ $(RUSTC) --target x86_64-pc-windows-gnu --print cfg | $(CGREP) x86_64
+ $(RUSTC) --target i686-pc-windows-msvc --print cfg | $(CGREP) msvc
+ $(RUSTC) --target i686-apple-darwin --print cfg | $(CGREP) macos
+ $(RUSTC) --target i686-unknown-linux-gnu --print cfg | $(CGREP) gnu
+ $(RUSTC) --target arm-unknown-linux-gnueabihf --print cfg | $(CGREP) target_abi=
+ $(RUSTC) --target arm-unknown-linux-gnueabihf --print cfg | $(CGREP) eabihf
+
+ifdef IS_WINDOWS
+default:
+ $(RUSTC) --print cfg | $(CGREP) windows
+else
+default:
+ $(RUSTC) --print cfg | $(CGREP) unix
+endif