summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/relocation-model/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /src/test/run-make-fulldeps/relocation-model/Makefile
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/relocation-model/Makefile')
-rw-r--r--src/test/run-make-fulldeps/relocation-model/Makefile19
1 files changed, 0 insertions, 19 deletions
diff --git a/src/test/run-make-fulldeps/relocation-model/Makefile b/src/test/run-make-fulldeps/relocation-model/Makefile
deleted file mode 100644
index a31dbfd91..000000000
--- a/src/test/run-make-fulldeps/relocation-model/Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
-include ../tools.mk
-
-all: others
- $(RUSTC) -C relocation-model=dynamic-no-pic foo.rs
- $(call RUN,foo)
-
- $(RUSTC) -C relocation-model=default foo.rs
- $(call RUN,foo)
-
- $(RUSTC) -C relocation-model=dynamic-no-pic --crate-type=dylib foo.rs --emit=link,obj
-
-ifdef IS_MSVC
-# FIXME(#28026)
-others:
-else
-others:
- $(RUSTC) -C relocation-model=static foo.rs
- $(call RUN,foo)
-endif