summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/relocation-model
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/relocation-model
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/relocation-model')
-rw-r--r--src/test/run-make-fulldeps/relocation-model/Makefile19
-rw-r--r--src/test/run-make-fulldeps/relocation-model/foo.rs1
2 files changed, 20 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/relocation-model/Makefile b/src/test/run-make-fulldeps/relocation-model/Makefile
new file mode 100644
index 000000000..485ecbb4b
--- /dev/null
+++ b/src/test/run-make-fulldeps/relocation-model/Makefile
@@ -0,0 +1,19 @@
+-include ../tools.mk
+
+all: others
+ $(RUSTC) -C relocation-model=dynamic-no-pic foo.rs
+ $(call RUN,foo)
+
+ $(RUSTC) -C relocation-model=default foo.rs
+ $(call RUN,foo)
+
+ $(RUSTC) -C relocation-model=dynamic-no-pic --crate-type=dylib foo.rs --emit=link,obj
+
+ifdef IS_MSVC
+# FIXME(#28026)
+others:
+else
+others:
+ $(RUSTC) -C relocation-model=static foo.rs
+ $(call RUN,foo)
+endif
diff --git a/src/test/run-make-fulldeps/relocation-model/foo.rs b/src/test/run-make-fulldeps/relocation-model/foo.rs
new file mode 100644
index 000000000..da0f5d925
--- /dev/null
+++ b/src/test/run-make-fulldeps/relocation-model/foo.rs
@@ -0,0 +1 @@
+pub fn main() {}