summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/relro-levels
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/relro-levels
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/relro-levels')
-rw-r--r--src/test/run-make-fulldeps/relro-levels/Makefile21
-rw-r--r--src/test/run-make-fulldeps/relro-levels/hello.rs3
2 files changed, 24 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/relro-levels/Makefile b/src/test/run-make-fulldeps/relro-levels/Makefile
new file mode 100644
index 000000000..aacb5acb7
--- /dev/null
+++ b/src/test/run-make-fulldeps/relro-levels/Makefile
@@ -0,0 +1,21 @@
+-include ../tools.mk
+
+# only-linux
+#
+# This tests the different -Zrelro-level values, and makes sure that they work properly.
+
+all:
+ # Ensure that binaries built with the full relro level links them with both
+ # RELRO and BIND_NOW for doing eager symbol resolving.
+ $(RUSTC) -Zrelro-level=full hello.rs
+ readelf -l $(TMPDIR)/hello | grep -q GNU_RELRO
+ readelf -d $(TMPDIR)/hello | grep -q BIND_NOW
+
+ $(RUSTC) -Zrelro-level=partial hello.rs
+ readelf -l $(TMPDIR)/hello | grep -q GNU_RELRO
+
+ # Ensure that we're *not* built with RELRO when setting it to off. We do
+ # not want to check for BIND_NOW however, as the linker might have that
+ # enabled by default.
+ $(RUSTC) -Zrelro-level=off hello.rs
+ ! readelf -l $(TMPDIR)/hello | grep -q GNU_RELRO
diff --git a/src/test/run-make-fulldeps/relro-levels/hello.rs b/src/test/run-make-fulldeps/relro-levels/hello.rs
new file mode 100644
index 000000000..e7a11a969
--- /dev/null
+++ b/src/test/run-make-fulldeps/relro-levels/hello.rs
@@ -0,0 +1,3 @@
+fn main() {
+ println!("Hello, world!");
+}