summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/return-non-c-like-enum
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/return-non-c-like-enum
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/return-non-c-like-enum')
-rw-r--r--src/test/run-make-fulldeps/return-non-c-like-enum/Makefile7
-rw-r--r--src/test/run-make-fulldeps/return-non-c-like-enum/nonclike.rs21
-rw-r--r--src/test/run-make-fulldeps/return-non-c-like-enum/test.c63
3 files changed, 91 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/return-non-c-like-enum/Makefile b/src/test/run-make-fulldeps/return-non-c-like-enum/Makefile
new file mode 100644
index 000000000..5b5d620ef
--- /dev/null
+++ b/src/test/run-make-fulldeps/return-non-c-like-enum/Makefile
@@ -0,0 +1,7 @@
+-include ../tools.mk
+
+all:
+ $(RUSTC) --crate-type=staticlib nonclike.rs
+ $(CC) test.c $(call STATICLIB,nonclike) $(call OUT_EXE,test) \
+ $(EXTRACFLAGS) $(EXTRACXXFLAGS)
+ $(call RUN,test)
diff --git a/src/test/run-make-fulldeps/return-non-c-like-enum/nonclike.rs b/src/test/run-make-fulldeps/return-non-c-like-enum/nonclike.rs
new file mode 100644
index 000000000..de529cf64
--- /dev/null
+++ b/src/test/run-make-fulldeps/return-non-c-like-enum/nonclike.rs
@@ -0,0 +1,21 @@
+#[repr(C, u8)]
+pub enum TT {
+ AA(u64, u64),
+ BB,
+}
+
+#[no_mangle]
+pub extern "C" fn tt_new(a: u64, b: u64) -> TT {
+ TT::AA(a, b)
+}
+
+#[repr(C,u8)]
+pub enum T {
+ A(u64),
+ B,
+}
+
+#[no_mangle]
+pub extern "C" fn t_new(a: u64) -> T {
+ T::A(a)
+}
diff --git a/src/test/run-make-fulldeps/return-non-c-like-enum/test.c b/src/test/run-make-fulldeps/return-non-c-like-enum/test.c
new file mode 100644
index 000000000..afadd3c10
--- /dev/null
+++ b/src/test/run-make-fulldeps/return-non-c-like-enum/test.c
@@ -0,0 +1,63 @@
+#include <stdint.h>
+#include <assert.h>
+
+/* This is the code generated by cbindgen 0.12.1 for the `enum TT`
+ * type in nonclike.rs . */
+enum TT_Tag {
+ AA,
+ BB,
+};
+typedef uint8_t TT_Tag;
+
+typedef struct {
+ uint64_t _0;
+ uint64_t _1;
+} AA_Body;
+
+typedef struct {
+ TT_Tag tag;
+ union {
+ AA_Body aa;
+ };
+} TT;
+
+/* This is the code generated by cbindgen 0.12.1 for the `enum T` type
+ * in nonclike.rs . */
+enum T_Tag {
+ A,
+ B,
+};
+typedef uint8_t T_Tag;
+
+typedef struct {
+ uint64_t _0;
+} A_Body;
+
+typedef struct {
+ T_Tag tag;
+ union {
+ A_Body a;
+ };
+} T;
+
+/* These symbols are defined by the Rust staticlib built from
+ * nonclike.rs. */
+extern TT tt_new(uint64_t a, uint64_t b);
+extern T t_new(uint64_t v);
+
+int main(int argc, char *argv[]) {
+ (void)argc; (void)argv;
+
+ /* This example works. */
+ TT tt = tt_new(10, 20);
+ assert(AA == tt.tag);
+ assert(10 == tt.aa._0);
+ assert(20 == tt.aa._1);
+
+ /* This one used to segfault (see issue #68190). */
+ T t = t_new(10);
+ assert(A == t.tag);
+ assert(10 == t.a._0);
+
+ return 0;
+}