summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/rustdoc-io-error
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/rustdoc-io-error
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/rustdoc-io-error')
-rw-r--r--src/test/run-make-fulldeps/rustdoc-io-error/Makefile20
-rw-r--r--src/test/run-make-fulldeps/rustdoc-io-error/foo.rs1
2 files changed, 21 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/rustdoc-io-error/Makefile b/src/test/run-make-fulldeps/rustdoc-io-error/Makefile
new file mode 100644
index 000000000..f95fa88d4
--- /dev/null
+++ b/src/test/run-make-fulldeps/rustdoc-io-error/Makefile
@@ -0,0 +1,20 @@
+-include ../tools.mk
+
+# This test verifies that rustdoc doesn't ICE when it encounters an IO error
+# while generating files. Ideally this would be a rustdoc-ui test, so we could
+# verify the error message as well.
+
+# ignore-windows
+# The test uses `chmod`.
+
+OUTPUT_DIR := "$(TMPDIR)/rustdoc-io-error"
+
+# This test operates by creating a temporary directory and modifying its
+# permissions so that it is not writable. We have to take special care to set
+# the permissions back to normal so that it's able to be deleted later.
+all:
+ mkdir -p $(OUTPUT_DIR)
+ chmod u-w $(OUTPUT_DIR)
+ -$(shell $(RUSTDOC) -o $(OUTPUT_DIR) foo.rs)
+ chmod u+w $(OUTPUT_DIR)
+ exit $($(.SHELLSTATUS) -eq 1)
diff --git a/src/test/run-make-fulldeps/rustdoc-io-error/foo.rs b/src/test/run-make-fulldeps/rustdoc-io-error/foo.rs
new file mode 100644
index 000000000..4a835673a
--- /dev/null
+++ b/src/test/run-make-fulldeps/rustdoc-io-error/foo.rs
@@ -0,0 +1 @@
+pub struct Foo;