summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/rustdoc-themes/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/rustdoc-themes/Makefile
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/rustdoc-themes/Makefile')
-rw-r--r--src/test/run-make-fulldeps/rustdoc-themes/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/rustdoc-themes/Makefile b/src/test/run-make-fulldeps/rustdoc-themes/Makefile
new file mode 100644
index 000000000..f3d07b25c
--- /dev/null
+++ b/src/test/run-make-fulldeps/rustdoc-themes/Makefile
@@ -0,0 +1,10 @@
+-include ../tools.mk
+
+# Test that rustdoc will properly load in a theme file and display it in the theme selector.
+
+OUTPUT_DIR := "$(TMPDIR)/rustdoc-themes"
+
+all:
+ cp $(S)/src/librustdoc/html/static/css/themes/light.css $(TMPDIR)/test.css
+ $(RUSTDOC) -o $(OUTPUT_DIR) foo.rs --theme $(TMPDIR)/test.css
+ $(HTMLDOCCK) $(OUTPUT_DIR) foo.rs