summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/sepcomp-inlining
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /src/test/run-make-fulldeps/sepcomp-inlining
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/sepcomp-inlining')
-rw-r--r--src/test/run-make-fulldeps/sepcomp-inlining/Makefile15
-rw-r--r--src/test/run-make-fulldeps/sepcomp-inlining/foo.rs30
2 files changed, 0 insertions, 45 deletions
diff --git a/src/test/run-make-fulldeps/sepcomp-inlining/Makefile b/src/test/run-make-fulldeps/sepcomp-inlining/Makefile
deleted file mode 100644
index 327aeb75e..000000000
--- a/src/test/run-make-fulldeps/sepcomp-inlining/Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
-include ../tools.mk
-
-# Test that #[inline] functions still get inlined across compilation unit
-# boundaries. Compilation should produce three IR files, but only the two
-# compilation units that have a usage of the #[inline] function should
-# contain a definition. Also, the non-#[inline] function should be defined
-# in only one compilation unit.
-
-all:
- $(RUSTC) foo.rs --emit=llvm-ir -C codegen-units=3 \
- -Z inline-in-all-cgus
- [ "$$(cat "$(TMPDIR)"/foo.*.ll | grep -c define\ i32\ .*inlined)" -eq "0" ]
- [ "$$(cat "$(TMPDIR)"/foo.*.ll | grep -c define\ internal\ i32\ .*inlined)" -eq "2" ]
- [ "$$(cat "$(TMPDIR)"/foo.*.ll | grep -c define\ hidden\ i32\ .*normal)" -eq "1" ]
- [ "$$(cat "$(TMPDIR)"/foo.*.ll | grep -c declare\ hidden\ i32\ .*normal)" -eq "2" ]
diff --git a/src/test/run-make-fulldeps/sepcomp-inlining/foo.rs b/src/test/run-make-fulldeps/sepcomp-inlining/foo.rs
deleted file mode 100644
index 2fe5f9cb7..000000000
--- a/src/test/run-make-fulldeps/sepcomp-inlining/foo.rs
+++ /dev/null
@@ -1,30 +0,0 @@
-#![feature(start)]
-
-#[inline]
-fn inlined() -> u32 {
- 1234
-}
-
-fn normal() -> u32 {
- 2345
-}
-
-mod a {
- pub fn f() -> u32 {
- ::inlined() + ::normal()
- }
-}
-
-mod b {
- pub fn f() -> u32 {
- ::inlined() + ::normal()
- }
-}
-
-#[start]
-fn start(_: isize, _: *const *const u8) -> isize {
- a::f();
- b::f();
-
- 0
-}