summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/sepcomp-separate
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /src/test/run-make-fulldeps/sepcomp-separate
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/sepcomp-separate')
-rw-r--r--src/test/run-make-fulldeps/sepcomp-separate/Makefile9
-rw-r--r--src/test/run-make-fulldeps/sepcomp-separate/foo.rs21
2 files changed, 0 insertions, 30 deletions
diff --git a/src/test/run-make-fulldeps/sepcomp-separate/Makefile b/src/test/run-make-fulldeps/sepcomp-separate/Makefile
deleted file mode 100644
index 62cf54a88..000000000
--- a/src/test/run-make-fulldeps/sepcomp-separate/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-include ../tools.mk
-
-# Test that separate compilation actually puts code into separate compilation
-# units. `foo.rs` defines `magic_fn` in three different modules, which should
-# wind up in three different compilation units.
-
-all:
- $(RUSTC) foo.rs --emit=llvm-ir -C codegen-units=3
- [ "$$(cat "$(TMPDIR)"/foo.*.ll | grep -c define\ .*magic_fn)" -eq "3" ]
diff --git a/src/test/run-make-fulldeps/sepcomp-separate/foo.rs b/src/test/run-make-fulldeps/sepcomp-separate/foo.rs
deleted file mode 100644
index 169bafa9b..000000000
--- a/src/test/run-make-fulldeps/sepcomp-separate/foo.rs
+++ /dev/null
@@ -1,21 +0,0 @@
-fn magic_fn() -> usize {
- 1234
-}
-
-mod a {
- pub fn magic_fn() -> usize {
- 2345
- }
-}
-
-mod b {
- pub fn magic_fn() -> usize {
- 3456
- }
-}
-
-fn main() {
- magic_fn();
- a::magic_fn();
- b::magic_fn();
-}