summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/symlinked-rlib/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/symlinked-rlib/Makefile
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/symlinked-rlib/Makefile')
-rw-r--r--src/test/run-make-fulldeps/symlinked-rlib/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/symlinked-rlib/Makefile b/src/test/run-make-fulldeps/symlinked-rlib/Makefile
new file mode 100644
index 000000000..996989ce4
--- /dev/null
+++ b/src/test/run-make-fulldeps/symlinked-rlib/Makefile
@@ -0,0 +1,9 @@
+-include ../tools.mk
+
+# ignore-windows
+# `ln` is actually `cp` on msys.
+
+all:
+ $(RUSTC) foo.rs --crate-type=rlib -o $(TMPDIR)/foo.xxx
+ ln -nsf $(TMPDIR)/foo.xxx $(TMPDIR)/libfoo.rlib
+ $(RUSTC) bar.rs -L $(TMPDIR)