summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/target-cpu-native/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /src/test/run-make-fulldeps/target-cpu-native/Makefile
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/target-cpu-native/Makefile')
-rw-r--r--src/test/run-make-fulldeps/target-cpu-native/Makefile20
1 files changed, 0 insertions, 20 deletions
diff --git a/src/test/run-make-fulldeps/target-cpu-native/Makefile b/src/test/run-make-fulldeps/target-cpu-native/Makefile
deleted file mode 100644
index eb3ca1e13..000000000
--- a/src/test/run-make-fulldeps/target-cpu-native/Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
-include ../tools.mk
-
-# only-linux
-# only-x86_64
-#
-# I *really* don't want to deal with a cross-platform way to compare file sizes,
-# tests in `make` sort of are awful
-
-all: $(TMPDIR)/out.log
- # Make sure no warnings about "unknown CPU `native`" were emitted
- if [ "$$(wc -c $(TMPDIR)/out.log | cut -d' ' -f 1)" = "0" ]; then \
- echo no warnings generated; \
- else \
- exit 1; \
- fi
-
-
-$(TMPDIR)/out.log:
- $(RUSTC) foo.rs -C target-cpu=native 2>&1 | tee $(TMPDIR)/out.log
- $(call RUN,foo)