summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/test-harness
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/test/run-make-fulldeps/test-harness
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make-fulldeps/test-harness')
-rw-r--r--src/test/run-make-fulldeps/test-harness/Makefile8
-rw-r--r--src/test/run-make-fulldeps/test-harness/test-ignore-cfg.rs9
2 files changed, 17 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/test-harness/Makefile b/src/test/run-make-fulldeps/test-harness/Makefile
new file mode 100644
index 000000000..39477c07c
--- /dev/null
+++ b/src/test/run-make-fulldeps/test-harness/Makefile
@@ -0,0 +1,8 @@
+-include ../tools.mk
+
+all:
+ # check that #[cfg_attr(..., ignore)] does the right thing.
+ $(RUSTC) --test test-ignore-cfg.rs --cfg ignorecfg
+ $(call RUN,test-ignore-cfg) | $(CGREP) 'shouldnotignore ... ok' 'shouldignore ... ignored'
+ $(call RUN,test-ignore-cfg --quiet) | $(CGREP) -e "^i\.$$"
+ $(call RUN,test-ignore-cfg --quiet) | $(CGREP) -v 'should'
diff --git a/src/test/run-make-fulldeps/test-harness/test-ignore-cfg.rs b/src/test/run-make-fulldeps/test-harness/test-ignore-cfg.rs
new file mode 100644
index 000000000..31ef131f2
--- /dev/null
+++ b/src/test/run-make-fulldeps/test-harness/test-ignore-cfg.rs
@@ -0,0 +1,9 @@
+#[test]
+#[cfg_attr(ignorecfg, ignore)]
+fn shouldignore() {
+}
+
+#[test]
+#[cfg_attr(noignorecfg, ignore)]
+fn shouldnotignore() {
+}