summaryrefslogtreecommitdiffstats
path: root/src/test/run-make/export-executable-symbols
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /src/test/run-make/export-executable-symbols
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make/export-executable-symbols')
-rw-r--r--src/test/run-make/export-executable-symbols/Makefile11
-rw-r--r--src/test/run-make/export-executable-symbols/main.rs8
2 files changed, 0 insertions, 19 deletions
diff --git a/src/test/run-make/export-executable-symbols/Makefile b/src/test/run-make/export-executable-symbols/Makefile
deleted file mode 100644
index daa77c99d..000000000
--- a/src/test/run-make/export-executable-symbols/Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
-include ../../run-make-fulldeps/tools.mk
-
-# ignore-wasm32
-# ignore-wasm64
-# ignore-none no-std is not supported
-# only-linux
-
-all:
- $(RUSTC) -Zexport-executable-symbols main.rs --target $(TARGET) --crate-type=bin
- nm $(TMPDIR)/main | $(CGREP) exported_symbol
-
diff --git a/src/test/run-make/export-executable-symbols/main.rs b/src/test/run-make/export-executable-symbols/main.rs
deleted file mode 100644
index c498381a3..000000000
--- a/src/test/run-make/export-executable-symbols/main.rs
+++ /dev/null
@@ -1,8 +0,0 @@
-// edition:2018
-
-fn main() {}
-
-#[no_mangle]
-pub fn exported_symbol() -> i8 {
- 42
-}