summaryrefslogtreecommitdiffstats
path: root/src/test/run-make/fmt-write-bloat
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /src/test/run-make/fmt-write-bloat
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make/fmt-write-bloat')
-rw-r--r--src/test/run-make/fmt-write-bloat/Makefile25
-rw-r--r--src/test/run-make/fmt-write-bloat/main.rs32
2 files changed, 0 insertions, 57 deletions
diff --git a/src/test/run-make/fmt-write-bloat/Makefile b/src/test/run-make/fmt-write-bloat/Makefile
deleted file mode 100644
index 07e6e025e..000000000
--- a/src/test/run-make/fmt-write-bloat/Makefile
+++ /dev/null
@@ -1,25 +0,0 @@
-include ../../run-make-fulldeps/tools.mk
-
-# ignore-windows
-
-ifeq ($(shell $(RUSTC) -vV | grep 'host: $(TARGET)'),)
-
-# Don't run this test when cross compiling.
-all:
-
-else
-
-NM = nm
-
-PANIC_SYMS = panic_bounds_check pad_integral Display Debug
-
-# Allow for debug_assert!() in debug builds of std.
-ifdef NO_DEBUG_ASSERTIONS
-PANIC_SYMS += panicking panic_fmt
-endif
-
-all: main.rs
- $(RUSTC) $< -O
- $(NM) $(call RUN_BINFILE,main) | $(CGREP) -v $(PANIC_SYMS)
-
-endif
diff --git a/src/test/run-make/fmt-write-bloat/main.rs b/src/test/run-make/fmt-write-bloat/main.rs
deleted file mode 100644
index e86c48014..000000000
--- a/src/test/run-make/fmt-write-bloat/main.rs
+++ /dev/null
@@ -1,32 +0,0 @@
-#![feature(lang_items)]
-#![feature(start)]
-#![no_std]
-
-use core::fmt;
-use core::fmt::Write;
-
-#[link(name = "c")]
-extern "C" {}
-
-struct Dummy;
-
-impl fmt::Write for Dummy {
- #[inline(never)]
- fn write_str(&mut self, _: &str) -> fmt::Result {
- Ok(())
- }
-}
-
-#[start]
-fn main(_: isize, _: *const *const u8) -> isize {
- let _ = writeln!(Dummy, "Hello World");
- 0
-}
-
-#[lang = "eh_personality"]
-fn eh_personality() {}
-
-#[panic_handler]
-fn panic(_: &core::panic::PanicInfo) -> ! {
- loop {}
-}