summaryrefslogtreecommitdiffstats
path: root/src/test/run-make/incr-foreign-head-span
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /src/test/run-make/incr-foreign-head-span
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make/incr-foreign-head-span')
-rw-r--r--src/test/run-make/incr-foreign-head-span/Makefile21
-rw-r--r--src/test/run-make/incr-foreign-head-span/first_crate.rs1
-rw-r--r--src/test/run-make/incr-foreign-head-span/second_crate.rs8
3 files changed, 0 insertions, 30 deletions
diff --git a/src/test/run-make/incr-foreign-head-span/Makefile b/src/test/run-make/incr-foreign-head-span/Makefile
deleted file mode 100644
index 712965eaa..000000000
--- a/src/test/run-make/incr-foreign-head-span/Makefile
+++ /dev/null
@@ -1,21 +0,0 @@
-include ../../run-make-fulldeps/tools.mk
-
-# ignore-none no-std is not supported
-# ignore-nvptx64-nvidia-cuda FIXME: can't find crate for 'std'
-
-# Ensure that modifying a crate on disk (without recompiling it)
-# does not cause ICEs in downstream crates.
-# Previously, we would call `SourceMap.guess_head_span` on a span
-# from an external crate, which would cause us to read an upstream
-# source file from disk during compilation of a downstream crate
-# See #86480 for more details
-
-INCR=$(TMPDIR)/incr
-
-all:
- cp first_crate.rs second_crate.rs $(TMPDIR)
- $(RUSTC) $(TMPDIR)/first_crate.rs -C incremental=$(INCR) --target $(TARGET) --crate-type lib
- $(RUSTC) $(TMPDIR)/second_crate.rs -C incremental=$(INCR) --target $(TARGET) --extern first-crate=$(TMPDIR) --crate-type lib
- rm $(TMPDIR)/first_crate.rs
- $(RUSTC) $(TMPDIR)/second_crate.rs -C incremental=$(INCR) --target $(TARGET) --cfg second_run --crate-type lib
-
diff --git a/src/test/run-make/incr-foreign-head-span/first_crate.rs b/src/test/run-make/incr-foreign-head-span/first_crate.rs
deleted file mode 100644
index 69dd103bf..000000000
--- a/src/test/run-make/incr-foreign-head-span/first_crate.rs
+++ /dev/null
@@ -1 +0,0 @@
-pub trait OtherTrait {}
diff --git a/src/test/run-make/incr-foreign-head-span/second_crate.rs b/src/test/run-make/incr-foreign-head-span/second_crate.rs
deleted file mode 100644
index 102f6b26c..000000000
--- a/src/test/run-make/incr-foreign-head-span/second_crate.rs
+++ /dev/null
@@ -1,8 +0,0 @@
-extern crate first_crate;
-use first_crate::OtherTrait;
-
-#[cfg(not(second_run))]
-trait Foo: OtherTrait {}
-
-#[cfg(second_run)]
-trait Bar: OtherTrait {}