summaryrefslogtreecommitdiffstats
path: root/src/test/run-make/wasm-custom-section
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
commita4b7ed7a42c716ab9f05e351f003d589124fd55d (patch)
treeb620cd3f223850b28716e474e80c58059dca5dd4 /src/test/run-make/wasm-custom-section
parentAdding upstream version 1.67.1+dfsg1. (diff)
downloadrustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.tar.xz
rustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.zip
Adding upstream version 1.68.2+dfsg1.upstream/1.68.2+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/run-make/wasm-custom-section')
-rw-r--r--src/test/run-make/wasm-custom-section/Makefile8
-rw-r--r--src/test/run-make/wasm-custom-section/bar.rs13
-rw-r--r--src/test/run-make/wasm-custom-section/foo.js36
-rw-r--r--src/test/run-make/wasm-custom-section/foo.rs8
4 files changed, 0 insertions, 65 deletions
diff --git a/src/test/run-make/wasm-custom-section/Makefile b/src/test/run-make/wasm-custom-section/Makefile
deleted file mode 100644
index 92b0802e3..000000000
--- a/src/test/run-make/wasm-custom-section/Makefile
+++ /dev/null
@@ -1,8 +0,0 @@
-include ../../run-make-fulldeps/tools.mk
-
-# only-wasm32-bare
-
-all:
- $(RUSTC) foo.rs --target wasm32-unknown-unknown
- $(RUSTC) bar.rs -C lto -O --target wasm32-unknown-unknown
- $(NODE) foo.js $(TMPDIR)/bar.wasm
diff --git a/src/test/run-make/wasm-custom-section/bar.rs b/src/test/run-make/wasm-custom-section/bar.rs
deleted file mode 100644
index c95f3e143..000000000
--- a/src/test/run-make/wasm-custom-section/bar.rs
+++ /dev/null
@@ -1,13 +0,0 @@
-#![crate_type = "cdylib"]
-#![deny(warnings)]
-
-extern crate foo;
-
-#[link_section = "foo"]
-pub static A: [u8; 2] = [5, 6];
-
-#[link_section = "baz"]
-pub static B: [u8; 2] = [7, 8];
-
-#[no_mangle]
-pub extern fn foo() {}
diff --git a/src/test/run-make/wasm-custom-section/foo.js b/src/test/run-make/wasm-custom-section/foo.js
deleted file mode 100644
index 57a0f5073..000000000
--- a/src/test/run-make/wasm-custom-section/foo.js
+++ /dev/null
@@ -1,36 +0,0 @@
-const fs = require('fs');
-const process = require('process');
-const assert = require('assert');
-const buffer = fs.readFileSync(process.argv[2]);
-
-let m = new WebAssembly.Module(buffer);
-let sections = WebAssembly.Module.customSections(m, "baz");
-console.log('section baz', sections);
-assert.strictEqual(sections.length, 1);
-let section = new Uint8Array(sections[0]);
-console.log('contents', section);
-assert.strictEqual(section.length, 2);
-assert.strictEqual(section[0], 7);
-assert.strictEqual(section[1], 8);
-
-sections = WebAssembly.Module.customSections(m, "bar");
-console.log('section bar', sections);
-assert.strictEqual(sections.length, 1, "didn't pick up `bar` section from dependency");
-section = new Uint8Array(sections[0]);
-console.log('contents', section);
-assert.strictEqual(section.length, 2);
-assert.strictEqual(section[0], 3);
-assert.strictEqual(section[1], 4);
-
-sections = WebAssembly.Module.customSections(m, "foo");
-console.log('section foo', sections);
-assert.strictEqual(sections.length, 1, "didn't create `foo` section");
-section = new Uint8Array(sections[0]);
-console.log('contents', section);
-assert.strictEqual(section.length, 4, "didn't concatenate `foo` sections");
-assert.strictEqual(section[0], 5);
-assert.strictEqual(section[1], 6);
-assert.strictEqual(section[2], 1);
-assert.strictEqual(section[3], 2);
-
-process.exit(0);
diff --git a/src/test/run-make/wasm-custom-section/foo.rs b/src/test/run-make/wasm-custom-section/foo.rs
deleted file mode 100644
index 61f81f024..000000000
--- a/src/test/run-make/wasm-custom-section/foo.rs
+++ /dev/null
@@ -1,8 +0,0 @@
-#![crate_type = "rlib"]
-#![deny(warnings)]
-
-#[link_section = "foo"]
-pub static A: [u8; 2] = [1, 2];
-
-#[link_section = "bar"]
-pub static B: [u8; 2] = [3, 4];