summaryrefslogtreecommitdiffstats
path: root/src/test/ui/async-await/suggest-switching-edition-on-await-cargo.rs
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /src/test/ui/async-await/suggest-switching-edition-on-await-cargo.rs
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/ui/async-await/suggest-switching-edition-on-await-cargo.rs')
-rw-r--r--src/test/ui/async-await/suggest-switching-edition-on-await-cargo.rs47
1 files changed, 0 insertions, 47 deletions
diff --git a/src/test/ui/async-await/suggest-switching-edition-on-await-cargo.rs b/src/test/ui/async-await/suggest-switching-edition-on-await-cargo.rs
deleted file mode 100644
index 4919e0a05..000000000
--- a/src/test/ui/async-await/suggest-switching-edition-on-await-cargo.rs
+++ /dev/null
@@ -1,47 +0,0 @@
-// rustc-env:CARGO=/usr/bin/cargo
-
-use std::pin::Pin;
-use std::future::Future;
-
-fn main() {}
-
-fn await_on_struct_missing() {
- struct S;
- let x = S;
- x.await;
- //~^ ERROR no field `await` on type
- //~| NOTE unknown field
- //~| NOTE to `.await` a `Future`, switch to Rust 2018
- //~| HELP set `edition = "2021"` in `Cargo.toml`
- //~| NOTE for more on editions, read https://doc.rust-lang.org/edition-guide
-}
-
-fn await_on_struct_similar() {
- struct S {
- awai: u8,
- }
- let x = S { awai: 42 };
- x.await;
- //~^ ERROR no field `await` on type
- //~| HELP a field with a similar name exists
- //~| NOTE to `.await` a `Future`, switch to Rust 2018
- //~| HELP set `edition = "2021"` in `Cargo.toml`
- //~| NOTE for more on editions, read https://doc.rust-lang.org/edition-guide
-}
-
-fn await_on_63533(x: Pin<&mut dyn Future<Output = ()>>) {
- x.await;
- //~^ ERROR no field `await` on type
- //~| NOTE unknown field
- //~| NOTE to `.await` a `Future`, switch to Rust 2018
- //~| HELP set `edition = "2021"` in `Cargo.toml`
- //~| NOTE for more on editions, read https://doc.rust-lang.org/edition-guide
-}
-
-fn await_on_apit(x: impl Future<Output = ()>) {
- x.await;
- //~^ ERROR no field `await` on type
- //~| NOTE to `.await` a `Future`, switch to Rust 2018
- //~| HELP set `edition = "2021"` in `Cargo.toml`
- //~| NOTE for more on editions, read https://doc.rust-lang.org/edition-guide
-}