summaryrefslogtreecommitdiffstats
path: root/src/tools/clippy/tests/versioncheck.rs
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:32 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:32 +0000
commit4547b622d8d29df964fa2914213088b148c498fc (patch)
tree9fc6b25f3c3add6b745be9a2400a6e96140046e9 /src/tools/clippy/tests/versioncheck.rs
parentReleasing progress-linux version 1.66.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-4547b622d8d29df964fa2914213088b148c498fc.tar.xz
rustc-4547b622d8d29df964fa2914213088b148c498fc.zip
Merging upstream version 1.67.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/tools/clippy/tests/versioncheck.rs')
-rw-r--r--src/tools/clippy/tests/versioncheck.rs15
1 files changed, 10 insertions, 5 deletions
diff --git a/src/tools/clippy/tests/versioncheck.rs b/src/tools/clippy/tests/versioncheck.rs
index a6d8d0307..7a85386a3 100644
--- a/src/tools/clippy/tests/versioncheck.rs
+++ b/src/tools/clippy/tests/versioncheck.rs
@@ -6,7 +6,7 @@ use rustc_tools_util::VersionInfo;
use std::fs;
#[test]
-fn check_that_clippy_lints_and_clippy_utils_have_the_same_version_as_clippy() {
+fn consistent_clippy_crate_versions() {
fn read_version(path: &str) -> String {
let contents = fs::read_to_string(path).unwrap_or_else(|e| panic!("error reading `{path}`: {e:?}"));
contents
@@ -24,11 +24,16 @@ fn check_that_clippy_lints_and_clippy_utils_have_the_same_version_as_clippy() {
}
let clippy_version = read_version("Cargo.toml");
- let clippy_lints_version = read_version("clippy_lints/Cargo.toml");
- let clippy_utils_version = read_version("clippy_utils/Cargo.toml");
- assert_eq!(clippy_version, clippy_lints_version);
- assert_eq!(clippy_version, clippy_utils_version);
+ let paths = [
+ "declare_clippy_lint/Cargo.toml",
+ "clippy_lints/Cargo.toml",
+ "clippy_utils/Cargo.toml",
+ ];
+
+ for path in paths {
+ assert_eq!(clippy_version, read_version(path), "{path} version differs");
+ }
}
#[test]