summaryrefslogtreecommitdiffstats
path: root/src/tools/rustdoc
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /src/tools/rustdoc
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/tools/rustdoc')
-rw-r--r--src/tools/rustdoc/Cargo.toml17
-rw-r--r--src/tools/rustdoc/main.rs3
2 files changed, 20 insertions, 0 deletions
diff --git a/src/tools/rustdoc/Cargo.toml b/src/tools/rustdoc/Cargo.toml
new file mode 100644
index 000000000..c4101f72c
--- /dev/null
+++ b/src/tools/rustdoc/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "rustdoc-tool"
+version = "0.0.0"
+edition = "2021"
+
+# Cargo adds a number of paths to the dylib search path on windows, which results in
+# the wrong rustdoc being executed. To avoid the conflicting rustdocs, we name the "tool"
+# rustdoc a different name.
+[[bin]]
+name = "rustdoc_tool_binary"
+path = "main.rs"
+
+[dependencies]
+rustdoc = { path = "../../librustdoc" }
+
+[features]
+jemalloc = ['rustdoc/jemalloc']
diff --git a/src/tools/rustdoc/main.rs b/src/tools/rustdoc/main.rs
new file mode 100644
index 000000000..5b499a1fa
--- /dev/null
+++ b/src/tools/rustdoc/main.rs
@@ -0,0 +1,3 @@
+fn main() {
+ rustdoc::main()
+}