summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile')
-rw-r--r--tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile11
1 files changed, 0 insertions, 11 deletions
diff --git a/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile b/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile
deleted file mode 100644
index 60d9c7c37..000000000
--- a/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
-include ../tools.mk
-
-# Test that -A warnings makes the 'empty trait list for derive' warning go away
-OUT=$(shell $(RUSTC) foo.rs -A warnings 2>&1 | grep "warning" )
-
-all: foo
- test -z '$(OUT)'
-
-# This is just to make sure the above command actually succeeds
-foo:
- $(RUSTC) foo.rs -A warnings