summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
commita4b7ed7a42c716ab9f05e351f003d589124fd55d (patch)
treeb620cd3f223850b28716e474e80c58059dca5dd4 /tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile
parentAdding upstream version 1.67.1+dfsg1. (diff)
downloadrustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.tar.xz
rustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.zip
Adding upstream version 1.68.2+dfsg1.upstream/1.68.2+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile')
-rw-r--r--tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile b/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile
new file mode 100644
index 000000000..60d9c7c37
--- /dev/null
+++ b/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile
@@ -0,0 +1,11 @@
+include ../tools.mk
+
+# Test that -A warnings makes the 'empty trait list for derive' warning go away
+OUT=$(shell $(RUSTC) foo.rs -A warnings 2>&1 | grep "warning" )
+
+all: foo
+ test -z '$(OUT)'
+
+# This is just to make sure the above command actually succeeds
+foo:
+ $(RUSTC) foo.rs -A warnings