summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/arguments-non-c-like-enum
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
commita4b7ed7a42c716ab9f05e351f003d589124fd55d (patch)
treeb620cd3f223850b28716e474e80c58059dca5dd4 /tests/run-make-fulldeps/arguments-non-c-like-enum
parentAdding upstream version 1.67.1+dfsg1. (diff)
downloadrustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.tar.xz
rustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.zip
Adding upstream version 1.68.2+dfsg1.upstream/1.68.2+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/arguments-non-c-like-enum')
-rw-r--r--tests/run-make-fulldeps/arguments-non-c-like-enum/Makefile7
-rw-r--r--tests/run-make-fulldeps/arguments-non-c-like-enum/nonclike.rs31
-rw-r--r--tests/run-make-fulldeps/arguments-non-c-like-enum/test.c66
3 files changed, 104 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/arguments-non-c-like-enum/Makefile b/tests/run-make-fulldeps/arguments-non-c-like-enum/Makefile
new file mode 100644
index 000000000..513311c82
--- /dev/null
+++ b/tests/run-make-fulldeps/arguments-non-c-like-enum/Makefile
@@ -0,0 +1,7 @@
+include ../tools.mk
+
+all:
+ $(RUSTC) --crate-type=staticlib nonclike.rs
+ $(CC) test.c $(call STATICLIB,nonclike) $(call OUT_EXE,test) \
+ $(EXTRACFLAGS) $(EXTRACXXFLAGS)
+ $(call RUN,test)
diff --git a/tests/run-make-fulldeps/arguments-non-c-like-enum/nonclike.rs b/tests/run-make-fulldeps/arguments-non-c-like-enum/nonclike.rs
new file mode 100644
index 000000000..57c2c6127
--- /dev/null
+++ b/tests/run-make-fulldeps/arguments-non-c-like-enum/nonclike.rs
@@ -0,0 +1,31 @@
+#[repr(C, u8)]
+pub enum TT {
+ AA(u64, u64),
+ BB,
+}
+
+#[no_mangle]
+pub extern "C" fn tt_add(a: TT, b: TT) -> u64 {
+ match (a, b) {
+ (TT::AA(a1, b1), TT::AA(a2, b2)) => a1 + a2 + b1 + b2,
+ (TT::AA(a1, b1), TT::BB) => a1 + b1,
+ (TT::BB, TT::AA(a1, b1)) => a1 + b1,
+ _ => 0,
+ }
+}
+
+#[repr(C, u8)]
+pub enum T {
+ A(u64),
+ B,
+}
+
+#[no_mangle]
+pub extern "C" fn t_add(a: T, b: T) -> u64 {
+ match (a, b) {
+ (T::A(a), T::A(b)) => a + b,
+ (T::A(a), T::B) => a,
+ (T::B, T::A(b)) => b,
+ _ => 0,
+ }
+}
diff --git a/tests/run-make-fulldeps/arguments-non-c-like-enum/test.c b/tests/run-make-fulldeps/arguments-non-c-like-enum/test.c
new file mode 100644
index 000000000..0a1621e49
--- /dev/null
+++ b/tests/run-make-fulldeps/arguments-non-c-like-enum/test.c
@@ -0,0 +1,66 @@
+#include <stdint.h>
+#include <assert.h>
+
+#include <stdio.h>
+
+/* This is the code generated by cbindgen 0.12.1 for the `enum TT`
+ * type in nonclike.rs . */
+enum TT_Tag {
+ AA,
+ BB,
+};
+typedef uint8_t TT_Tag;
+
+typedef struct {
+ uint64_t _0;
+ uint64_t _1;
+} AA_Body;
+
+typedef struct {
+ TT_Tag tag;
+ union {
+ AA_Body aa;
+ };
+} TT;
+
+/* This is the code generated by cbindgen 0.12.1 for the `enum T` type
+ * in nonclike.rs . */
+enum T_Tag {
+ A,
+ B,
+};
+typedef uint8_t T_Tag;
+
+typedef struct {
+ uint64_t _0;
+} A_Body;
+
+typedef struct {
+ T_Tag tag;
+ union {
+ A_Body a;
+ };
+} T;
+
+/* These symbols are defined by the Rust staticlib built from
+ * nonclike.rs. */
+extern uint64_t t_add(T a, T b);
+extern uint64_t tt_add(TT a, TT b);
+
+int main(int argc, char *argv[]) {
+ (void)argc; (void)argv;
+
+ /* This example works. */
+ TT xx = { .tag = AA, .aa = { ._0 = 1, ._1 = 2 } };
+ TT yy = { .tag = AA, .aa = { ._0 = 10, ._1 = 20 } };
+ uint64_t rr = tt_add(xx, yy);
+ assert(33 == rr);
+
+ /* This one used to return an incorrect result (see issue #68190). */
+ T x = { .tag = A, .a = { ._0 = 1 } };
+ T y = { .tag = A, .a = { ._0 = 10 } };
+ uint64_t r = t_add(x, y);
+ assert(11 == r);
+
+ return 0;
+}