summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/c-dynamic-dylib/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
commita4b7ed7a42c716ab9f05e351f003d589124fd55d (patch)
treeb620cd3f223850b28716e474e80c58059dca5dd4 /tests/run-make-fulldeps/c-dynamic-dylib/Makefile
parentAdding upstream version 1.67.1+dfsg1. (diff)
downloadrustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.tar.xz
rustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.zip
Adding upstream version 1.68.2+dfsg1.upstream/1.68.2+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/c-dynamic-dylib/Makefile')
-rw-r--r--tests/run-make-fulldeps/c-dynamic-dylib/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/c-dynamic-dylib/Makefile b/tests/run-make-fulldeps/c-dynamic-dylib/Makefile
new file mode 100644
index 000000000..ac6877892
--- /dev/null
+++ b/tests/run-make-fulldeps/c-dynamic-dylib/Makefile
@@ -0,0 +1,12 @@
+include ../tools.mk
+
+# ignore-macos
+#
+# This hits an assertion in the linker on older versions of osx apparently
+
+all: $(call DYLIB,cfoo)
+ $(RUSTC) foo.rs -C prefer-dynamic
+ $(RUSTC) bar.rs
+ $(call RUN,bar)
+ $(call REMOVE_DYLIBS,cfoo)
+ $(call FAIL,bar)