summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/c-link-to-rust-dylib
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
commita4b7ed7a42c716ab9f05e351f003d589124fd55d (patch)
treeb620cd3f223850b28716e474e80c58059dca5dd4 /tests/run-make-fulldeps/c-link-to-rust-dylib
parentAdding upstream version 1.67.1+dfsg1. (diff)
downloadrustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.tar.xz
rustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.zip
Adding upstream version 1.68.2+dfsg1.upstream/1.68.2+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/c-link-to-rust-dylib')
-rw-r--r--tests/run-make-fulldeps/c-link-to-rust-dylib/Makefile17
-rw-r--r--tests/run-make-fulldeps/c-link-to-rust-dylib/bar.c6
-rw-r--r--tests/run-make-fulldeps/c-link-to-rust-dylib/foo.rs4
3 files changed, 27 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/c-link-to-rust-dylib/Makefile b/tests/run-make-fulldeps/c-link-to-rust-dylib/Makefile
new file mode 100644
index 000000000..2a371b545
--- /dev/null
+++ b/tests/run-make-fulldeps/c-link-to-rust-dylib/Makefile
@@ -0,0 +1,17 @@
+include ../tools.mk
+
+all: $(TMPDIR)/$(call BIN,bar)
+ $(call RUN,bar)
+ $(call REMOVE_DYLIBS,foo)
+ $(call FAIL,bar)
+
+ifdef IS_MSVC
+$(TMPDIR)/$(call BIN,bar): $(call DYLIB,foo)
+ $(CC) bar.c $(TMPDIR)/foo.dll.lib $(call OUT_EXE,bar)
+else
+$(TMPDIR)/$(call BIN,bar): $(call DYLIB,foo)
+ $(CC) bar.c -lfoo -o $(call RUN_BINFILE,bar) -L $(TMPDIR)
+endif
+
+$(call DYLIB,foo): foo.rs
+ $(RUSTC) foo.rs
diff --git a/tests/run-make-fulldeps/c-link-to-rust-dylib/bar.c b/tests/run-make-fulldeps/c-link-to-rust-dylib/bar.c
new file mode 100644
index 000000000..bb4036b06
--- /dev/null
+++ b/tests/run-make-fulldeps/c-link-to-rust-dylib/bar.c
@@ -0,0 +1,6 @@
+void foo();
+
+int main() {
+ foo();
+ return 0;
+}
diff --git a/tests/run-make-fulldeps/c-link-to-rust-dylib/foo.rs b/tests/run-make-fulldeps/c-link-to-rust-dylib/foo.rs
new file mode 100644
index 000000000..f197fa513
--- /dev/null
+++ b/tests/run-make-fulldeps/c-link-to-rust-dylib/foo.rs
@@ -0,0 +1,4 @@
+#![crate_type = "dylib"]
+
+#[no_mangle]
+pub extern "C" fn foo() {}