summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/c-static-dylib
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /tests/run-make-fulldeps/c-static-dylib
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/c-static-dylib')
-rw-r--r--tests/run-make-fulldeps/c-static-dylib/Makefile9
-rw-r--r--tests/run-make-fulldeps/c-static-dylib/bar.rs5
-rw-r--r--tests/run-make-fulldeps/c-static-dylib/cfoo.c1
-rw-r--r--tests/run-make-fulldeps/c-static-dylib/foo.rs10
4 files changed, 25 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/c-static-dylib/Makefile b/tests/run-make-fulldeps/c-static-dylib/Makefile
new file mode 100644
index 000000000..5b78005e3
--- /dev/null
+++ b/tests/run-make-fulldeps/c-static-dylib/Makefile
@@ -0,0 +1,9 @@
+include ../tools.mk
+
+all: $(call NATIVE_STATICLIB,cfoo)
+ $(RUSTC) foo.rs -C prefer-dynamic
+ $(RUSTC) bar.rs
+ rm $(call NATIVE_STATICLIB,cfoo)
+ $(call RUN,bar)
+ $(call REMOVE_DYLIBS,foo)
+ $(call FAIL,bar)
diff --git a/tests/run-make-fulldeps/c-static-dylib/bar.rs b/tests/run-make-fulldeps/c-static-dylib/bar.rs
new file mode 100644
index 000000000..b8c798ffd
--- /dev/null
+++ b/tests/run-make-fulldeps/c-static-dylib/bar.rs
@@ -0,0 +1,5 @@
+extern crate foo;
+
+fn main() {
+ foo::rsfoo();
+}
diff --git a/tests/run-make-fulldeps/c-static-dylib/cfoo.c b/tests/run-make-fulldeps/c-static-dylib/cfoo.c
new file mode 100644
index 000000000..9fe07f82f
--- /dev/null
+++ b/tests/run-make-fulldeps/c-static-dylib/cfoo.c
@@ -0,0 +1 @@
+int foo() { return 0; }
diff --git a/tests/run-make-fulldeps/c-static-dylib/foo.rs b/tests/run-make-fulldeps/c-static-dylib/foo.rs
new file mode 100644
index 000000000..1e8af4d44
--- /dev/null
+++ b/tests/run-make-fulldeps/c-static-dylib/foo.rs
@@ -0,0 +1,10 @@
+#![crate_type = "dylib"]
+
+#[link(name = "cfoo", kind = "static")]
+extern "C" {
+ fn foo();
+}
+
+pub fn rsfoo() {
+ unsafe { foo() }
+}