summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/cdylib-fewer-symbols
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make-fulldeps/cdylib-fewer-symbols
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/cdylib-fewer-symbols')
-rw-r--r--tests/run-make-fulldeps/cdylib-fewer-symbols/Makefile12
-rw-r--r--tests/run-make-fulldeps/cdylib-fewer-symbols/foo.rs6
2 files changed, 0 insertions, 18 deletions
diff --git a/tests/run-make-fulldeps/cdylib-fewer-symbols/Makefile b/tests/run-make-fulldeps/cdylib-fewer-symbols/Makefile
deleted file mode 100644
index 324791af8..000000000
--- a/tests/run-make-fulldeps/cdylib-fewer-symbols/Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
-# Test that allocator-related symbols don't show up as exported from a cdylib as
-# they're internal to Rust and not part of the public ABI.
-
-include ../tools.mk
-
-# ignore-windows
-# FIXME: The __rdl_ and __rust_ symbol still remains, no matter using MSVC or GNU
-# See https://github.com/rust-lang/rust/pull/46207#issuecomment-347561753
-
-all:
- $(RUSTC) foo.rs
- nm -g "$(call DYLIB,foo)" | $(CGREP) -v __rdl_ __rde_ __rg_ __rust_
diff --git a/tests/run-make-fulldeps/cdylib-fewer-symbols/foo.rs b/tests/run-make-fulldeps/cdylib-fewer-symbols/foo.rs
deleted file mode 100644
index af37bc8e9..000000000
--- a/tests/run-make-fulldeps/cdylib-fewer-symbols/foo.rs
+++ /dev/null
@@ -1,6 +0,0 @@
-#![crate_type = "cdylib"]
-
-#[no_mangle]
-pub extern "C" fn foo() -> u32 {
- 3
-}