summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/cdylib/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /tests/run-make-fulldeps/cdylib/Makefile
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/cdylib/Makefile')
-rw-r--r--tests/run-make-fulldeps/cdylib/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/cdylib/Makefile b/tests/run-make-fulldeps/cdylib/Makefile
new file mode 100644
index 000000000..47ec762b3
--- /dev/null
+++ b/tests/run-make-fulldeps/cdylib/Makefile
@@ -0,0 +1,19 @@
+include ../tools.mk
+
+all: $(call RUN_BINFILE,foo)
+ $(call RUN,foo)
+ rm $(call DYLIB,foo)
+ $(RUSTC) foo.rs -C lto
+ $(call RUN,foo)
+
+ifdef IS_MSVC
+$(call RUN_BINFILE,foo): $(call DYLIB,foo)
+ $(CC) $(CFLAGS) foo.c $(TMPDIR)/foo.dll.lib $(call OUT_EXE,foo)
+else
+$(call RUN_BINFILE,foo): $(call DYLIB,foo)
+ $(CC) $(CFLAGS) foo.c -lfoo -o $(call RUN_BINFILE,foo) -L $(TMPDIR)
+endif
+
+$(call DYLIB,foo):
+ $(RUSTC) bar.rs
+ $(RUSTC) foo.rs