summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/crate-data-smoke
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
commita4b7ed7a42c716ab9f05e351f003d589124fd55d (patch)
treeb620cd3f223850b28716e474e80c58059dca5dd4 /tests/run-make-fulldeps/crate-data-smoke
parentAdding upstream version 1.67.1+dfsg1. (diff)
downloadrustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.tar.xz
rustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.zip
Adding upstream version 1.68.2+dfsg1.upstream/1.68.2+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/crate-data-smoke')
-rw-r--r--tests/run-make-fulldeps/crate-data-smoke/Makefile10
-rw-r--r--tests/run-make-fulldeps/crate-data-smoke/crate.rs7
-rw-r--r--tests/run-make-fulldeps/crate-data-smoke/lib.rs2
-rw-r--r--tests/run-make-fulldeps/crate-data-smoke/rlib.rs2
4 files changed, 21 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/crate-data-smoke/Makefile b/tests/run-make-fulldeps/crate-data-smoke/Makefile
new file mode 100644
index 000000000..a453f65ff
--- /dev/null
+++ b/tests/run-make-fulldeps/crate-data-smoke/Makefile
@@ -0,0 +1,10 @@
+include ../tools.mk
+
+all:
+ [ `$(RUSTC) --print crate-name crate.rs` = "foo" ]
+ [ `$(RUSTC) --print file-names crate.rs` = "$(call BIN,foo)" ]
+ [ `$(RUSTC) --print file-names --crate-type=lib \
+ --test crate.rs` = "$(call BIN,foo)" ]
+ [ `$(RUSTC) --print file-names --test lib.rs` = "$(call BIN,mylib)" ]
+ $(RUSTC) --print file-names lib.rs
+ $(RUSTC) --print file-names rlib.rs
diff --git a/tests/run-make-fulldeps/crate-data-smoke/crate.rs b/tests/run-make-fulldeps/crate-data-smoke/crate.rs
new file mode 100644
index 000000000..a48a6f51c
--- /dev/null
+++ b/tests/run-make-fulldeps/crate-data-smoke/crate.rs
@@ -0,0 +1,7 @@
+#![crate_name = "foo"]
+
+// Querying about the crate metadata should *not* parse the entire crate, it
+// only needs the crate attributes (which are guaranteed to be at the top) be
+// sure that if we have an error like a missing module that we can still query
+// about the crate id.
+mod error;
diff --git a/tests/run-make-fulldeps/crate-data-smoke/lib.rs b/tests/run-make-fulldeps/crate-data-smoke/lib.rs
new file mode 100644
index 000000000..8002f11ec
--- /dev/null
+++ b/tests/run-make-fulldeps/crate-data-smoke/lib.rs
@@ -0,0 +1,2 @@
+#![crate_name = "mylib"]
+#![crate_type = "lib"]
diff --git a/tests/run-make-fulldeps/crate-data-smoke/rlib.rs b/tests/run-make-fulldeps/crate-data-smoke/rlib.rs
new file mode 100644
index 000000000..47fcce4a7
--- /dev/null
+++ b/tests/run-make-fulldeps/crate-data-smoke/rlib.rs
@@ -0,0 +1,2 @@
+#![crate_name = "mylib"]
+#![crate_type = "rlib"]