summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/issue-11908
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make-fulldeps/issue-11908
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/issue-11908')
-rw-r--r--tests/run-make-fulldeps/issue-11908/Makefile21
-rw-r--r--tests/run-make-fulldeps/issue-11908/bar.rs3
-rw-r--r--tests/run-make-fulldeps/issue-11908/foo.rs1
3 files changed, 0 insertions, 25 deletions
diff --git a/tests/run-make-fulldeps/issue-11908/Makefile b/tests/run-make-fulldeps/issue-11908/Makefile
deleted file mode 100644
index 47005537e..000000000
--- a/tests/run-make-fulldeps/issue-11908/Makefile
+++ /dev/null
@@ -1,21 +0,0 @@
-# This test ensures that if you have the same rlib or dylib at two locations
-# in the same path that you don't hit an assertion in the compiler.
-#
-# Note that this relies on `liburl` to be in the path somewhere else,
-# and then our aux-built libraries will collide with liburl (they have
-# the same version listed)
-
-include ../tools.mk
-
-all:
- mkdir $(TMPDIR)/other
- $(RUSTC) foo.rs --crate-type=dylib -C prefer-dynamic
- mv $(call DYLIB,foo) $(TMPDIR)/other
- $(RUSTC) foo.rs --crate-type=dylib -C prefer-dynamic
- $(RUSTC) bar.rs -L $(TMPDIR)/other
- rm -rf $(TMPDIR)
- mkdir -p $(TMPDIR)/other
- $(RUSTC) foo.rs --crate-type=rlib
- mv $(TMPDIR)/libfoo.rlib $(TMPDIR)/other
- $(RUSTC) foo.rs --crate-type=rlib
- $(RUSTC) bar.rs -L $(TMPDIR)/other
diff --git a/tests/run-make-fulldeps/issue-11908/bar.rs b/tests/run-make-fulldeps/issue-11908/bar.rs
deleted file mode 100644
index bb7b36c49..000000000
--- a/tests/run-make-fulldeps/issue-11908/bar.rs
+++ /dev/null
@@ -1,3 +0,0 @@
-extern crate foo;
-
-fn main() {}
diff --git a/tests/run-make-fulldeps/issue-11908/foo.rs b/tests/run-make-fulldeps/issue-11908/foo.rs
deleted file mode 100644
index 82b2dfe9f..000000000
--- a/tests/run-make-fulldeps/issue-11908/foo.rs
+++ /dev/null
@@ -1 +0,0 @@
-#![crate_name = "foo"]