summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/issue-51671
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make-fulldeps/issue-51671
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/issue-51671')
-rw-r--r--tests/run-make-fulldeps/issue-51671/Makefile9
-rw-r--r--tests/run-make-fulldeps/issue-51671/app.rs20
2 files changed, 0 insertions, 29 deletions
diff --git a/tests/run-make-fulldeps/issue-51671/Makefile b/tests/run-make-fulldeps/issue-51671/Makefile
deleted file mode 100644
index c93645369..000000000
--- a/tests/run-make-fulldeps/issue-51671/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-include ../tools.mk
-
-# ignore-windows-msvc
-
-all:
- $(RUSTC) --emit=obj app.rs
- nm $(TMPDIR)/app.o | $(CGREP) rust_begin_unwind
- nm $(TMPDIR)/app.o | $(CGREP) rust_eh_personality
- nm $(TMPDIR)/app.o | $(CGREP) __rg_oom
diff --git a/tests/run-make-fulldeps/issue-51671/app.rs b/tests/run-make-fulldeps/issue-51671/app.rs
deleted file mode 100644
index e9dc1e974..000000000
--- a/tests/run-make-fulldeps/issue-51671/app.rs
+++ /dev/null
@@ -1,20 +0,0 @@
-#![crate_type = "bin"]
-#![feature(lang_items, alloc_error_handler)]
-#![no_main]
-#![no_std]
-
-use core::alloc::Layout;
-use core::panic::PanicInfo;
-
-#[panic_handler]
-fn panic(_: &PanicInfo) -> ! {
- loop {}
-}
-
-#[lang = "eh_personality"]
-fn eh() {}
-
-#[alloc_error_handler]
-fn oom(_: Layout) -> ! {
- loop {}
-}