summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/issue-7349
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /tests/run-make-fulldeps/issue-7349
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/issue-7349')
-rw-r--r--tests/run-make-fulldeps/issue-7349/Makefile11
-rw-r--r--tests/run-make-fulldeps/issue-7349/foo.rs22
2 files changed, 33 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/issue-7349/Makefile b/tests/run-make-fulldeps/issue-7349/Makefile
new file mode 100644
index 000000000..dc073b77f
--- /dev/null
+++ b/tests/run-make-fulldeps/issue-7349/Makefile
@@ -0,0 +1,11 @@
+include ../tools.mk
+
+# Test to make sure that inner functions within a polymorphic outer function
+# don't get re-codegened when the outer function is monomorphized. The test
+# code monomorphizes the outer functions several times, but the magic constants
+# used in the inner functions should each appear only once in the generated IR.
+
+all:
+ $(RUSTC) foo.rs --emit=llvm-ir
+ [ "$$(grep -c 'ret i32 8675309' "$(TMPDIR)/foo.ll")" -eq "1" ]
+ [ "$$(grep -c 'ret i32 11235813' "$(TMPDIR)/foo.ll")" -eq "1" ]
diff --git a/tests/run-make-fulldeps/issue-7349/foo.rs b/tests/run-make-fulldeps/issue-7349/foo.rs
new file mode 100644
index 000000000..246a12595
--- /dev/null
+++ b/tests/run-make-fulldeps/issue-7349/foo.rs
@@ -0,0 +1,22 @@
+fn outer<T>() {
+ #[allow(dead_code)]
+ fn inner() -> u32 {
+ 8675309
+ }
+ inner();
+}
+
+extern "C" fn outer_foreign<T>() {
+ #[allow(dead_code)]
+ fn inner() -> u32 {
+ 11235813
+ }
+ inner();
+}
+
+fn main() {
+ outer::<isize>();
+ outer::<usize>();
+ outer_foreign::<isize>();
+ outer_foreign::<usize>();
+}