summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/lto-dylib-dep
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
commita4b7ed7a42c716ab9f05e351f003d589124fd55d (patch)
treeb620cd3f223850b28716e474e80c58059dca5dd4 /tests/run-make-fulldeps/lto-dylib-dep
parentAdding upstream version 1.67.1+dfsg1. (diff)
downloadrustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.tar.xz
rustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.zip
Adding upstream version 1.68.2+dfsg1.upstream/1.68.2+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/lto-dylib-dep')
-rw-r--r--tests/run-make-fulldeps/lto-dylib-dep/Makefile10
-rw-r--r--tests/run-make-fulldeps/lto-dylib-dep/a_dylib.rs3
-rw-r--r--tests/run-make-fulldeps/lto-dylib-dep/main.rs5
3 files changed, 18 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/lto-dylib-dep/Makefile b/tests/run-make-fulldeps/lto-dylib-dep/Makefile
new file mode 100644
index 000000000..41487b23c
--- /dev/null
+++ b/tests/run-make-fulldeps/lto-dylib-dep/Makefile
@@ -0,0 +1,10 @@
+include ../tools.mk
+
+# Test that we don't run into an assertion when using a Rust dylib dependency
+# while compiling with full LTO.
+# See https://github.com/rust-lang/rust/issues/59137
+
+all:
+ $(RUSTC) a_dylib.rs --crate-type=dylib -C prefer-dynamic
+ $(RUSTC) main.rs -C lto
+ $(call RUN,main)
diff --git a/tests/run-make-fulldeps/lto-dylib-dep/a_dylib.rs b/tests/run-make-fulldeps/lto-dylib-dep/a_dylib.rs
new file mode 100644
index 000000000..e63457e6e
--- /dev/null
+++ b/tests/run-make-fulldeps/lto-dylib-dep/a_dylib.rs
@@ -0,0 +1,3 @@
+pub fn foo() {
+ println!("bar");
+}
diff --git a/tests/run-make-fulldeps/lto-dylib-dep/main.rs b/tests/run-make-fulldeps/lto-dylib-dep/main.rs
new file mode 100644
index 000000000..4fb3c4730
--- /dev/null
+++ b/tests/run-make-fulldeps/lto-dylib-dep/main.rs
@@ -0,0 +1,5 @@
+extern crate a_dylib;
+
+fn main() {
+ a_dylib::foo();
+}