summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/lto-empty
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
commita4b7ed7a42c716ab9f05e351f003d589124fd55d (patch)
treeb620cd3f223850b28716e474e80c58059dca5dd4 /tests/run-make-fulldeps/lto-empty
parentAdding upstream version 1.67.1+dfsg1. (diff)
downloadrustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.tar.xz
rustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.zip
Adding upstream version 1.68.2+dfsg1.upstream/1.68.2+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/lto-empty')
-rw-r--r--tests/run-make-fulldeps/lto-empty/Makefile12
-rw-r--r--tests/run-make-fulldeps/lto-empty/lib.rs1
2 files changed, 13 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/lto-empty/Makefile b/tests/run-make-fulldeps/lto-empty/Makefile
new file mode 100644
index 000000000..b4345ba18
--- /dev/null
+++ b/tests/run-make-fulldeps/lto-empty/Makefile
@@ -0,0 +1,12 @@
+include ../tools.mk
+
+all: cdylib-fat cdylib-thin
+
+cdylib-fat:
+ $(RUSTC) lib.rs -C lto=fat -C opt-level=3 -C incremental=$(TMPDIR)/inc-fat
+ $(RUSTC) lib.rs -C lto=fat -C opt-level=3 -C incremental=$(TMPDIR)/inc-fat
+
+cdylib-thin:
+ $(RUSTC) lib.rs -C lto=thin -C opt-level=3 -C incremental=$(TMPDIR)/inc-thin
+ $(RUSTC) lib.rs -C lto=thin -C opt-level=3 -C incremental=$(TMPDIR)/inc-thin
+
diff --git a/tests/run-make-fulldeps/lto-empty/lib.rs b/tests/run-make-fulldeps/lto-empty/lib.rs
new file mode 100644
index 000000000..e3663c790
--- /dev/null
+++ b/tests/run-make-fulldeps/lto-empty/lib.rs
@@ -0,0 +1 @@
+#![crate_type = "cdylib"]