summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/obey-crate-type-flag/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
commita4b7ed7a42c716ab9f05e351f003d589124fd55d (patch)
treeb620cd3f223850b28716e474e80c58059dca5dd4 /tests/run-make-fulldeps/obey-crate-type-flag/Makefile
parentAdding upstream version 1.67.1+dfsg1. (diff)
downloadrustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.tar.xz
rustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.zip
Adding upstream version 1.68.2+dfsg1.upstream/1.68.2+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/obey-crate-type-flag/Makefile')
-rw-r--r--tests/run-make-fulldeps/obey-crate-type-flag/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/obey-crate-type-flag/Makefile b/tests/run-make-fulldeps/obey-crate-type-flag/Makefile
new file mode 100644
index 000000000..effcfc94c
--- /dev/null
+++ b/tests/run-make-fulldeps/obey-crate-type-flag/Makefile
@@ -0,0 +1,13 @@
+include ../tools.mk
+
+# check that rustc builds all crate_type attributes
+# delete rlib
+# delete whatever dylib is made for this system
+# check that rustc only builds --crate-type flags, ignoring attributes
+# fail if an rlib was built
+all:
+ $(RUSTC) test.rs
+ $(call REMOVE_RLIBS,test)
+ $(call REMOVE_DYLIBS,test)
+ $(RUSTC) --crate-type dylib test.rs
+ $(call REMOVE_RLIBS,test) && exit 1 || exit 0