summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/output-filename-overwrites-input
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
commita4b7ed7a42c716ab9f05e351f003d589124fd55d (patch)
treeb620cd3f223850b28716e474e80c58059dca5dd4 /tests/run-make-fulldeps/output-filename-overwrites-input
parentAdding upstream version 1.67.1+dfsg1. (diff)
downloadrustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.tar.xz
rustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.zip
Adding upstream version 1.68.2+dfsg1.upstream/1.68.2+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/output-filename-overwrites-input')
-rw-r--r--tests/run-make-fulldeps/output-filename-overwrites-input/Makefile13
-rw-r--r--tests/run-make-fulldeps/output-filename-overwrites-input/bar.rs1
-rw-r--r--tests/run-make-fulldeps/output-filename-overwrites-input/foo.rs1
3 files changed, 15 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/output-filename-overwrites-input/Makefile b/tests/run-make-fulldeps/output-filename-overwrites-input/Makefile
new file mode 100644
index 000000000..33069c06f
--- /dev/null
+++ b/tests/run-make-fulldeps/output-filename-overwrites-input/Makefile
@@ -0,0 +1,13 @@
+include ../tools.mk
+
+all:
+ cp foo.rs $(TMPDIR)/foo
+ $(RUSTC) $(TMPDIR)/foo -o $(TMPDIR)/foo 2>&1 \
+ | $(CGREP) -e "the input file \".*foo\" would be overwritten by the generated executable"
+ cp bar.rs $(TMPDIR)/bar.rlib
+ $(RUSTC) $(TMPDIR)/bar.rlib -o $(TMPDIR)/bar.rlib 2>&1 \
+ | $(CGREP) -e "the input file \".*bar.rlib\" would be overwritten by the generated executable"
+ $(RUSTC) foo.rs 2>&1 && $(RUSTC) -Z ls $(TMPDIR)/foo 2>&1
+ cp foo.rs $(TMPDIR)/foo.rs
+ $(RUSTC) $(TMPDIR)/foo.rs -o $(TMPDIR)/foo.rs 2>&1 \
+ | $(CGREP) -e "the input file \".*foo.rs\" would be overwritten by the generated executable"
diff --git a/tests/run-make-fulldeps/output-filename-overwrites-input/bar.rs b/tests/run-make-fulldeps/output-filename-overwrites-input/bar.rs
new file mode 100644
index 000000000..83be6e807
--- /dev/null
+++ b/tests/run-make-fulldeps/output-filename-overwrites-input/bar.rs
@@ -0,0 +1 @@
+#![crate_type = "lib"]
diff --git a/tests/run-make-fulldeps/output-filename-overwrites-input/foo.rs b/tests/run-make-fulldeps/output-filename-overwrites-input/foo.rs
new file mode 100644
index 000000000..f328e4d9d
--- /dev/null
+++ b/tests/run-make-fulldeps/output-filename-overwrites-input/foo.rs
@@ -0,0 +1 @@
+fn main() {}