summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/output-filename-overwrites-input
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make-fulldeps/output-filename-overwrites-input
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/output-filename-overwrites-input')
-rw-r--r--tests/run-make-fulldeps/output-filename-overwrites-input/Makefile13
-rw-r--r--tests/run-make-fulldeps/output-filename-overwrites-input/bar.rs1
-rw-r--r--tests/run-make-fulldeps/output-filename-overwrites-input/foo.rs1
3 files changed, 0 insertions, 15 deletions
diff --git a/tests/run-make-fulldeps/output-filename-overwrites-input/Makefile b/tests/run-make-fulldeps/output-filename-overwrites-input/Makefile
deleted file mode 100644
index 33069c06f..000000000
--- a/tests/run-make-fulldeps/output-filename-overwrites-input/Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
-include ../tools.mk
-
-all:
- cp foo.rs $(TMPDIR)/foo
- $(RUSTC) $(TMPDIR)/foo -o $(TMPDIR)/foo 2>&1 \
- | $(CGREP) -e "the input file \".*foo\" would be overwritten by the generated executable"
- cp bar.rs $(TMPDIR)/bar.rlib
- $(RUSTC) $(TMPDIR)/bar.rlib -o $(TMPDIR)/bar.rlib 2>&1 \
- | $(CGREP) -e "the input file \".*bar.rlib\" would be overwritten by the generated executable"
- $(RUSTC) foo.rs 2>&1 && $(RUSTC) -Z ls $(TMPDIR)/foo 2>&1
- cp foo.rs $(TMPDIR)/foo.rs
- $(RUSTC) $(TMPDIR)/foo.rs -o $(TMPDIR)/foo.rs 2>&1 \
- | $(CGREP) -e "the input file \".*foo.rs\" would be overwritten by the generated executable"
diff --git a/tests/run-make-fulldeps/output-filename-overwrites-input/bar.rs b/tests/run-make-fulldeps/output-filename-overwrites-input/bar.rs
deleted file mode 100644
index 83be6e807..000000000
--- a/tests/run-make-fulldeps/output-filename-overwrites-input/bar.rs
+++ /dev/null
@@ -1 +0,0 @@
-#![crate_type = "lib"]
diff --git a/tests/run-make-fulldeps/output-filename-overwrites-input/foo.rs b/tests/run-make-fulldeps/output-filename-overwrites-input/foo.rs
deleted file mode 100644
index f328e4d9d..000000000
--- a/tests/run-make-fulldeps/output-filename-overwrites-input/foo.rs
+++ /dev/null
@@ -1 +0,0 @@
-fn main() {}