summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/panic-impl-transitive
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /tests/run-make-fulldeps/panic-impl-transitive
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/panic-impl-transitive')
-rw-r--r--tests/run-make-fulldeps/panic-impl-transitive/Makefile7
-rw-r--r--tests/run-make-fulldeps/panic-impl-transitive/panic-impl-consumer.rs5
-rw-r--r--tests/run-make-fulldeps/panic-impl-transitive/panic-impl-provider.rs9
3 files changed, 21 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/panic-impl-transitive/Makefile b/tests/run-make-fulldeps/panic-impl-transitive/Makefile
new file mode 100644
index 000000000..c3192efcb
--- /dev/null
+++ b/tests/run-make-fulldeps/panic-impl-transitive/Makefile
@@ -0,0 +1,7 @@
+include ../../run-make-fulldeps/tools.mk
+
+# NOTE we use --emit=llvm-ir to avoid running the linker (linking will fail because there's no main
+# in this crate)
+all:
+ $(RUSTC) panic-impl-provider.rs
+ $(RUSTC) panic-impl-consumer.rs -C panic=abort --emit=llvm-ir -L $(TMPDIR)
diff --git a/tests/run-make-fulldeps/panic-impl-transitive/panic-impl-consumer.rs b/tests/run-make-fulldeps/panic-impl-transitive/panic-impl-consumer.rs
new file mode 100644
index 000000000..82a98b12d
--- /dev/null
+++ b/tests/run-make-fulldeps/panic-impl-transitive/panic-impl-consumer.rs
@@ -0,0 +1,5 @@
+#![no_std]
+#![no_main]
+
+// this crate provides the `panic_impl` lang item so we don't need to define it here
+extern crate panic_impl_provider;
diff --git a/tests/run-make-fulldeps/panic-impl-transitive/panic-impl-provider.rs b/tests/run-make-fulldeps/panic-impl-transitive/panic-impl-provider.rs
new file mode 100644
index 000000000..f1b9873c8
--- /dev/null
+++ b/tests/run-make-fulldeps/panic-impl-transitive/panic-impl-provider.rs
@@ -0,0 +1,9 @@
+#![crate_type = "rlib"]
+#![no_std]
+
+use core::panic::PanicInfo;
+
+#[panic_handler]
+fn panic(info: &PanicInfo) -> ! {
+ loop {}
+}