summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/pretty-expanded
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
commita4b7ed7a42c716ab9f05e351f003d589124fd55d (patch)
treeb620cd3f223850b28716e474e80c58059dca5dd4 /tests/run-make-fulldeps/pretty-expanded
parentAdding upstream version 1.67.1+dfsg1. (diff)
downloadrustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.tar.xz
rustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.zip
Adding upstream version 1.68.2+dfsg1.upstream/1.68.2+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/pretty-expanded')
-rw-r--r--tests/run-make-fulldeps/pretty-expanded/Makefile4
-rw-r--r--tests/run-make-fulldeps/pretty-expanded/input.rs12
2 files changed, 16 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/pretty-expanded/Makefile b/tests/run-make-fulldeps/pretty-expanded/Makefile
new file mode 100644
index 000000000..5a0097a83
--- /dev/null
+++ b/tests/run-make-fulldeps/pretty-expanded/Makefile
@@ -0,0 +1,4 @@
+include ../tools.mk
+
+all:
+ $(RUSTC) -o $(TMPDIR)/input.expanded.rs -Zunpretty=expanded input.rs
diff --git a/tests/run-make-fulldeps/pretty-expanded/input.rs b/tests/run-make-fulldeps/pretty-expanded/input.rs
new file mode 100644
index 000000000..af3d75b3b
--- /dev/null
+++ b/tests/run-make-fulldeps/pretty-expanded/input.rs
@@ -0,0 +1,12 @@
+#[crate_type="lib"]
+
+// #13544
+
+extern crate rustc_serialize;
+
+#[derive(RustcEncodable)] pub struct A;
+#[derive(RustcEncodable)] pub struct B(isize);
+#[derive(RustcEncodable)] pub struct C { x: isize }
+#[derive(RustcEncodable)] pub enum D {}
+#[derive(RustcEncodable)] pub enum E { y }
+#[derive(RustcEncodable)] pub enum F { z(isize) }