summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/print-cfg
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /tests/run-make-fulldeps/print-cfg
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/print-cfg')
-rw-r--r--tests/run-make-fulldeps/print-cfg/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/print-cfg/Makefile b/tests/run-make-fulldeps/print-cfg/Makefile
new file mode 100644
index 000000000..126f5768c
--- /dev/null
+++ b/tests/run-make-fulldeps/print-cfg/Makefile
@@ -0,0 +1,20 @@
+# needs-llvm-components: x86 arm
+
+include ../tools.mk
+
+all: default
+ $(RUSTC) --target x86_64-pc-windows-gnu --print cfg | $(CGREP) windows
+ $(RUSTC) --target x86_64-pc-windows-gnu --print cfg | $(CGREP) x86_64
+ $(RUSTC) --target i686-pc-windows-msvc --print cfg | $(CGREP) msvc
+ $(RUSTC) --target i686-apple-darwin --print cfg | $(CGREP) macos
+ $(RUSTC) --target i686-unknown-linux-gnu --print cfg | $(CGREP) gnu
+ $(RUSTC) --target arm-unknown-linux-gnueabihf --print cfg | $(CGREP) target_abi=
+ $(RUSTC) --target arm-unknown-linux-gnueabihf --print cfg | $(CGREP) eabihf
+
+ifdef IS_WINDOWS
+default:
+ $(RUSTC) --print cfg | $(CGREP) windows
+else
+default:
+ $(RUSTC) --print cfg | $(CGREP) unix
+endif