summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/rustdoc-error-lines
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
commita4b7ed7a42c716ab9f05e351f003d589124fd55d (patch)
treeb620cd3f223850b28716e474e80c58059dca5dd4 /tests/run-make-fulldeps/rustdoc-error-lines
parentAdding upstream version 1.67.1+dfsg1. (diff)
downloadrustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.tar.xz
rustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.zip
Adding upstream version 1.68.2+dfsg1.upstream/1.68.2+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/rustdoc-error-lines')
-rw-r--r--tests/run-make-fulldeps/rustdoc-error-lines/Makefile13
-rw-r--r--tests/run-make-fulldeps/rustdoc-error-lines/input.rs28
2 files changed, 41 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/rustdoc-error-lines/Makefile b/tests/run-make-fulldeps/rustdoc-error-lines/Makefile
new file mode 100644
index 000000000..2dc30f56b
--- /dev/null
+++ b/tests/run-make-fulldeps/rustdoc-error-lines/Makefile
@@ -0,0 +1,13 @@
+include ../tools.mk
+
+# Test that hir-tree output doesn't crash and includes
+# the string constant we would expect to see.
+
+all:
+ $(RUSTDOC) --test input.rs > $(TMPDIR)/output || true
+ $(CGREP) 'input.rs - foo (line 5)' < $(TMPDIR)/output
+ $(CGREP) 'input.rs:7:15' < $(TMPDIR)/output
+ $(CGREP) 'input.rs - bar (line 15)' < $(TMPDIR)/output
+ $(CGREP) 'input.rs:17:15' < $(TMPDIR)/output
+ $(CGREP) 'input.rs - bar (line 24)' < $(TMPDIR)/output
+ $(CGREP) 'input.rs:26:15' < $(TMPDIR)/output
diff --git a/tests/run-make-fulldeps/rustdoc-error-lines/input.rs b/tests/run-make-fulldeps/rustdoc-error-lines/input.rs
new file mode 100644
index 000000000..b4db182e8
--- /dev/null
+++ b/tests/run-make-fulldeps/rustdoc-error-lines/input.rs
@@ -0,0 +1,28 @@
+// Test for #45868
+
+// random #![feature] to ensure that crate attrs
+// do not offset things
+/// ```rust
+/// #![feature(bool_to_option)]
+/// let x: char = 1;
+/// ```
+pub fn foo() {
+
+}
+
+/// Add some text around the test...
+///
+/// ```rust
+/// #![feature(bool_to_option)]
+/// let x: char = 1;
+/// ```
+///
+/// ...to make sure that the line number is still correct.
+///
+/// Let's also add a second test in the same doc comment.
+///
+/// ```rust
+/// #![feature(bool_to_option)]
+/// let x: char = 1;
+/// ```
+pub fn bar() {}