summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/rustdoc-themes
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
commita4b7ed7a42c716ab9f05e351f003d589124fd55d (patch)
treeb620cd3f223850b28716e474e80c58059dca5dd4 /tests/run-make-fulldeps/rustdoc-themes
parentAdding upstream version 1.67.1+dfsg1. (diff)
downloadrustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.tar.xz
rustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.zip
Adding upstream version 1.68.2+dfsg1.upstream/1.68.2+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/rustdoc-themes')
-rw-r--r--tests/run-make-fulldeps/rustdoc-themes/Makefile10
-rw-r--r--tests/run-make-fulldeps/rustdoc-themes/foo.rs4
2 files changed, 14 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/rustdoc-themes/Makefile b/tests/run-make-fulldeps/rustdoc-themes/Makefile
new file mode 100644
index 000000000..a6d9a43ad
--- /dev/null
+++ b/tests/run-make-fulldeps/rustdoc-themes/Makefile
@@ -0,0 +1,10 @@
+include ../tools.mk
+
+# Test that rustdoc will properly load in a theme file and display it in the theme selector.
+
+OUTPUT_DIR := "$(TMPDIR)/rustdoc-themes"
+
+all:
+ cp $(S)/src/librustdoc/html/static/css/themes/light.css $(TMPDIR)/test.css
+ $(RUSTDOC) -o $(OUTPUT_DIR) foo.rs --theme $(TMPDIR)/test.css
+ $(HTMLDOCCK) $(OUTPUT_DIR) foo.rs
diff --git a/tests/run-make-fulldeps/rustdoc-themes/foo.rs b/tests/run-make-fulldeps/rustdoc-themes/foo.rs
new file mode 100644
index 000000000..58efaf7d5
--- /dev/null
+++ b/tests/run-make-fulldeps/rustdoc-themes/foo.rs
@@ -0,0 +1,4 @@
+// @has test.css
+// @has foo/struct.Foo.html
+// @has - '//link[@rel="stylesheet"]/@href' '../test.css'
+pub struct Foo;