summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/type-mismatch-same-crate-name/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
commita4b7ed7a42c716ab9f05e351f003d589124fd55d (patch)
treeb620cd3f223850b28716e474e80c58059dca5dd4 /tests/run-make-fulldeps/type-mismatch-same-crate-name/Makefile
parentAdding upstream version 1.67.1+dfsg1. (diff)
downloadrustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.tar.xz
rustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.zip
Adding upstream version 1.68.2+dfsg1.upstream/1.68.2+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/type-mismatch-same-crate-name/Makefile')
-rw-r--r--tests/run-make-fulldeps/type-mismatch-same-crate-name/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/type-mismatch-same-crate-name/Makefile b/tests/run-make-fulldeps/type-mismatch-same-crate-name/Makefile
new file mode 100644
index 000000000..9f4be7126
--- /dev/null
+++ b/tests/run-make-fulldeps/type-mismatch-same-crate-name/Makefile
@@ -0,0 +1,19 @@
+include ../tools.mk
+
+all:
+ # compile two different versions of crateA
+ $(RUSTC) --crate-type=rlib crateA.rs -C metadata=-1 -C extra-filename=-1
+ $(RUSTC) --crate-type=rlib crateA.rs -C metadata=-2 -C extra-filename=-2
+ # make crateB depend on version 1 of crateA
+ $(RUSTC) --crate-type=rlib crateB.rs --extern crateA=$(TMPDIR)/libcrateA-1.rlib
+ # make crateC depend on version 2 of crateA
+ $(RUSTC) crateC.rs --extern crateA=$(TMPDIR)/libcrateA-2.rlib 2>&1 | \
+ tr -d '\r\n' | $(CGREP) -e \
+ "mismatched types.*\
+ crateB::try_foo\(foo2\);.*\
+ expected struct \`crateA::foo::Foo\`, found struct \`Foo\`.*\
+ different versions of crate \`crateA\`.*\
+ mismatched types.*\
+ crateB::try_bar\(bar2\);.*\
+ expected trait \`crateA::bar::Bar\`, found trait \`Bar\`.*\
+ different versions of crate \`crateA\`"