summaryrefslogtreecommitdiffstats
path: root/tests/run-make/allow-warnings-cmdline-stability/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/allow-warnings-cmdline-stability/Makefile
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/allow-warnings-cmdline-stability/Makefile')
-rw-r--r--tests/run-make/allow-warnings-cmdline-stability/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/run-make/allow-warnings-cmdline-stability/Makefile b/tests/run-make/allow-warnings-cmdline-stability/Makefile
new file mode 100644
index 000000000..368a39af6
--- /dev/null
+++ b/tests/run-make/allow-warnings-cmdline-stability/Makefile
@@ -0,0 +1,16 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# Test that -A warnings makes the 'empty trait list for derive' warning go away
+DEP=$(shell $(RUSTC) bar.rs)
+OUT=$(shell $(RUSTC) foo.rs -A warnings 2>&1 | grep "warning" )
+
+all: foo bar
+ test -z '$(OUT)'
+
+# These are just to ensure that the above commands actually work
+bar:
+ $(RUSTC) bar.rs
+
+foo: bar
+ $(RUSTC) foo.rs -A warnings