summaryrefslogtreecommitdiffstats
path: root/tests/run-make/c-link-to-rust-dylib/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/c-link-to-rust-dylib/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/c-link-to-rust-dylib/Makefile')
-rw-r--r--tests/run-make/c-link-to-rust-dylib/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/run-make/c-link-to-rust-dylib/Makefile b/tests/run-make/c-link-to-rust-dylib/Makefile
new file mode 100644
index 000000000..2763cb6ed
--- /dev/null
+++ b/tests/run-make/c-link-to-rust-dylib/Makefile
@@ -0,0 +1,18 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: $(TMPDIR)/$(call BIN,bar)
+ $(call RUN,bar)
+ $(call REMOVE_DYLIBS,foo)
+ $(call FAIL,bar)
+
+ifdef IS_MSVC
+$(TMPDIR)/$(call BIN,bar): $(call DYLIB,foo)
+ $(CC) bar.c $(TMPDIR)/foo.dll.lib $(call OUT_EXE,bar)
+else
+$(TMPDIR)/$(call BIN,bar): $(call DYLIB,foo)
+ $(CC) bar.c -lfoo -o $(call RUN_BINFILE,bar) -L $(TMPDIR)
+endif
+
+$(call DYLIB,foo): foo.rs
+ $(RUSTC) foo.rs