summaryrefslogtreecommitdiffstats
path: root/tests/run-make/c-unwind-abi-catch-lib-panic/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/c-unwind-abi-catch-lib-panic/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/c-unwind-abi-catch-lib-panic/Makefile')
-rw-r--r--tests/run-make/c-unwind-abi-catch-lib-panic/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/run-make/c-unwind-abi-catch-lib-panic/Makefile b/tests/run-make/c-unwind-abi-catch-lib-panic/Makefile
new file mode 100644
index 000000000..9c41a5a71
--- /dev/null
+++ b/tests/run-make/c-unwind-abi-catch-lib-panic/Makefile
@@ -0,0 +1,31 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: archive
+ # Compile `main.rs`, which will link into our library, and run it.
+ $(RUSTC) main.rs
+ $(call RUN,main)
+
+ifdef IS_MSVC
+archive: add.o panic.o
+ # Now, create an archive using these two objects.
+ $(AR) crus $(TMPDIR)/add.lib $(TMPDIR)/add.o $(TMPDIR)/panic.o
+else
+archive: add.o panic.o
+ # Now, create an archive using these two objects.
+ $(AR) crus $(TMPDIR)/libadd.a $(TMPDIR)/add.o $(TMPDIR)/panic.o
+endif
+
+# Compile `panic.rs` into an object file.
+#
+# Note that we invoke `rustc` directly, so we may emit an object rather
+# than an archive. We'll do that later.
+panic.o:
+ $(BARE_RUSTC) $(RUSTFLAGS) \
+ --out-dir $(TMPDIR) \
+ --emit=obj panic.rs
+
+# Compile `add.c` into an object file.
+add.o:
+ $(call COMPILE_OBJ,$(TMPDIR)/add.o,add.c)
+