summaryrefslogtreecommitdiffstats
path: root/tests/run-make/cross-lang-lto/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/cross-lang-lto/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/cross-lang-lto/Makefile')
-rw-r--r--tests/run-make/cross-lang-lto/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/tests/run-make/cross-lang-lto/Makefile b/tests/run-make/cross-lang-lto/Makefile
new file mode 100644
index 000000000..92058f952
--- /dev/null
+++ b/tests/run-make/cross-lang-lto/Makefile
@@ -0,0 +1,57 @@
+
+include ../tools.mk
+
+# ignore windows due to libLLVM being present in PATH and the PATH and library path being the same
+# (so fixing it is harder). See #57765 for context
+ifndef IS_WINDOWS
+
+# This test makes sure that the object files we generate are actually
+# LLVM bitcode files (as used by linker LTO plugins) when compiling with
+# -Clinker-plugin-lto.
+
+# this only succeeds for bitcode files
+ASSERT_IS_BITCODE_OBJ=("$(LLVM_BIN_DIR)"/llvm-bcanalyzer $(1))
+EXTRACT_OBJS=(cd $(TMPDIR); rm -f ./*.o; "$(LLVM_BIN_DIR)"/llvm-ar x $(1))
+
+BUILD_LIB=$(RUSTC) lib.rs -Copt-level=2 -Clinker-plugin-lto -Ccodegen-units=1
+BUILD_EXE=$(RUSTC) main.rs -Copt-level=2 -Clinker-plugin-lto -Ccodegen-units=1 --emit=obj
+
+all: staticlib staticlib-fat-lto staticlib-thin-lto rlib exe cdylib rdylib
+
+staticlib: lib.rs
+ $(BUILD_LIB) --crate-type=staticlib -o $(TMPDIR)/liblib.a
+ $(call EXTRACT_OBJS, liblib.a)
+ for file in $(TMPDIR)/liblib.*.rcgu.o; do $(call ASSERT_IS_BITCODE_OBJ, $$file); done
+
+staticlib-fat-lto: lib.rs
+ $(BUILD_LIB) --crate-type=staticlib -o $(TMPDIR)/liblib-fat-lto.a -Clto=fat
+ $(call EXTRACT_OBJS, liblib-fat-lto.a)
+ for file in $(TMPDIR)/liblib-fat-lto.*.rcgu.o; do $(call ASSERT_IS_BITCODE_OBJ, $$file); done
+
+staticlib-thin-lto: lib.rs
+ $(BUILD_LIB) --crate-type=staticlib -o $(TMPDIR)/liblib-thin-lto.a -Clto=thin
+ $(call EXTRACT_OBJS, liblib-thin-lto.a)
+ for file in $(TMPDIR)/liblib-thin-lto.*.rcgu.o; do $(call ASSERT_IS_BITCODE_OBJ, $$file); done
+
+rlib: lib.rs
+ $(BUILD_LIB) --crate-type=rlib -o $(TMPDIR)/liblib.rlib
+ $(call EXTRACT_OBJS, liblib.rlib)
+ for file in $(TMPDIR)/liblib.*.rcgu.o; do $(call ASSERT_IS_BITCODE_OBJ, $$file); done
+
+cdylib: lib.rs
+ $(BUILD_LIB) --crate-type=cdylib --emit=obj -o $(TMPDIR)/cdylib.o
+ $(call ASSERT_IS_BITCODE_OBJ, $(TMPDIR)/cdylib.o)
+
+rdylib: lib.rs
+ $(BUILD_LIB) --crate-type=dylib --emit=obj -o $(TMPDIR)/rdylib.o
+ $(call ASSERT_IS_BITCODE_OBJ, $(TMPDIR)/rdylib.o)
+
+exe: lib.rs
+ $(BUILD_EXE) -o $(TMPDIR)/exe.o
+ $(call ASSERT_IS_BITCODE_OBJ, $(TMPDIR)/exe.o)
+
+else
+
+all:
+
+endif