summaryrefslogtreecommitdiffstats
path: root/tests/run-make/dep-info-spaces/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/dep-info-spaces/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/dep-info-spaces/Makefile')
-rw-r--r--tests/run-make/dep-info-spaces/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/run-make/dep-info-spaces/Makefile b/tests/run-make/dep-info-spaces/Makefile
new file mode 100644
index 000000000..0cfe513e4
--- /dev/null
+++ b/tests/run-make/dep-info-spaces/Makefile
@@ -0,0 +1,19 @@
+include ../tools.mk
+
+# ignore-windows
+# ignore-freebsd
+# FIXME: (windows: see `../dep-info/Makefile`)
+
+all:
+ cp lib.rs $(TMPDIR)/
+ cp 'foo foo.rs' $(TMPDIR)/
+ cp bar.rs $(TMPDIR)/
+ $(RUSTC) --emit link,dep-info --crate-type=lib $(TMPDIR)/lib.rs
+ sleep 1
+ touch $(TMPDIR)/'foo foo.rs'
+ -rm -f $(TMPDIR)/done
+ $(MAKE) -drf Makefile.foo
+ rm $(TMPDIR)/done
+ pwd
+ $(MAKE) -drf Makefile.foo
+ rm $(TMPDIR)/done && exit 1 || exit 0